Bug 868717 - Review Request: libtvdb - Library to retrieve TV series information from web
Review Request: libtvdb - Library to retrieve TV series information from web
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Volker Fröhlich
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 868947
  Show dependency treegraph
 
Reported: 2012-10-21 18:44 EDT by Daniel Vrátil
Modified: 2015-11-01 20:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 22:28:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
volker27: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Daniel Vrátil 2012-10-21 18:44:13 EDT
Spec URL: http://pub.progdan.cz/specs/libtvdb.spec
SRPM URL: http://pub.progdan.cz/specs/libtvdb-0.3.0-1.fc19.src.rpm
Description: A small Qt library to retrieve TV series information from thetvdb.com web service. The library is required by nepomuktvnamer.
Fedora Account System Username: dvratil
Koji Build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4613789
Comment 1 Jan Grulich 2012-10-22 10:57:31 EDT
I think you should use KDE macros like %{cmake_kde4}, %{_kde4_libdir} etc. You have also mistake in %changelog because entries must start with *.
Comment 2 Volker Fröhlich 2012-10-22 15:53:57 EDT
License seems to be LGPLv2+.

rm -rf $RPM_BUILD_ROOT is no longer necessary.

Drop the version requirement on cmake.

Mark ChangeLog as documentation and ask upstream to include a license file.
Comment 3 Daniel Vrátil 2012-10-23 12:31:30 EDT
Spec URL: http://pub.progdan.cz/specs/libtvdb.spec
SRPM URL: http://pub.progdan.cz/specs/libtvdb-0.3.0-2.fc18.src.rpm

* Tue Oct 23 2012 Dan Vrátil <dvratil@redhat.com> - 0.3.0-2
- Fixed license
- Marked ChangeLog as documentation
- Removed CMake version and "rm -rf $BUILD_ROOT"


Jan, this a pure Qt library, thus I don't use KDE4 macros here.
Comment 4 Kevin Kofler 2012-10-31 19:40:47 EDT
It BRs kdelibs-devel (BTW, better use kdelibs4-devel) and kde-runtime-devel, so it's not a pure Qt library.
Comment 5 Volker Fröhlich 2012-10-31 20:06:15 EDT
After reading through the license header again, Kevin Kofler explained to me, that the license must be "LGPLv2 or LGPLv3" and to "add a comment saying that newer versions approved by KDE e.V. are allowed".

If you want to place the cmake file in %datadir/cmake, you must require cmake for the devel sub-package.

Please use KDE macros, see https://fedoraproject.org/wiki/SIGs/KDE/Packaging/BestPractices for reference (ignore the anachronisms).

Please ask upstream to include a license file.
Comment 6 Daniel Vrátil 2012-11-06 09:42:06 EST
Spec URL: http://pub.progdan.cz/specs/libtvdb.spec
SRPM URL: http://pub.progdan.cz/specs/libtvdb-0.3.0-3.fc18.src.rpm

* Tue Nov 06 2012 Dan Vrátil <dvratil@redhat.com> - 0.3.0-3
- Fixed license
- Use KDE4 macros
- Added Cmake to -devel requires

I already contacted upstream when submitting the package for review to include a license file. The file will be included in next release.
Comment 7 Volker Fröhlich 2012-11-25 13:00:52 EST
I'm not sure if anything could be gained by removing the unused dependencies on shared libraries; See below!

tvdb_export.h claims LGPLv2+, which surprises me, in the face of the KDE exception. I suggest to inform upstream, if you agree that this finding is strange.

Besides that, this package is APPROVED.

Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated


===== MUST items =====

C/C++:
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig called in %post and %postun if required.
[x]: Package does not contain any libtool archives (.la)
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.

Also builds on PPC and PPC64

[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in %package
     devel
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[-]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.

Upstream doesn't include it, packager informed upstream.

[x]: License field in the package spec file matches the actual license^
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "LGPL", "LGPL (v2 or later)". 2 files have unknown license. Detailed
     output of licensecheck in
     /media/speicher1/makerpm/rpmbuild/SPECS/868717-libtvdb/licensecheck.txt

[-]: License file installed when any subpackage combination is installed.

See above!

[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[-]: If the package is under multiple licenses, the licensing breakdown must
     be documented in the spec.
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[-]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[x]: Useful -debuginfo package or justification otherwise.
[-]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: Package functions as described.

Client works

[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: Scriptlets must be sane, if used.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX / PatchY prefixed with %{name}.
[x]: SourceX is a working URL.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.

There are no tests.

[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: libtvdb-debuginfo-0.3.0-3.fc19.x86_64.rpm
          libtvdb-devel-0.3.0-3.fc19.x86_64.rpm
          libtvdb-0.3.0-3.fc19.x86_64.rpm
          libtvdb-0.3.0-3.fc19.src.rpm
libtvdb-devel.x86_64: W: no-documentation
libtvdb.x86_64: W: spelling-error Summary(en_US) thetvdb -> theta
libtvdb.x86_64: W: spelling-error %description -l en_US thetvdb -> theta
libtvdb.x86_64: W: no-manual-page-for-binary tvdbclient
libtvdb.src: W: spelling-error Summary(en_US) thetvdb -> theta
libtvdb.src: W: spelling-error %description -l en_US thetvdb -> theta
4 packages and 0 specfiles checked; 0 errors, 6 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint libtvdb libtvdb-devel libtvdb-debuginfo
libtvdb.x86_64: W: spelling-error Summary(en_US) thetvdb -> theta
libtvdb.x86_64: W: spelling-error %description -l en_US thetvdb -> theta
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libQtGui.so.4
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libkdeui.so.5
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libQtNetwork.so.4
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libQtXml.so.4
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libQtSvg.so.4
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libQtDBus.so.4
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libpthread.so.0
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libm.so.6
libtvdb.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libtvdb.so.0.3.0 /lib64/libgcc_s.so.1
libtvdb.x86_64: W: no-manual-page-for-binary tvdbclient
libtvdb-devel.x86_64: W: no-documentation
3 packages and 0 specfiles checked; 0 errors, 13 warnings.
# echo 'rpmlint-done:'



Requires
--------
libtvdb-debuginfo-0.3.0-3.fc19.x86_64.rpm (rpmlib, GLIBC filtered):
    

libtvdb-devel-0.3.0-3.fc19.x86_64.rpm (rpmlib, GLIBC filtered):
    
    cmake  
    libtvdb(x86-64) = 0.3.0-3.fc19
    libtvdb.so.0()(64bit)  

libtvdb-0.3.0-3.fc19.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /sbin/ldconfig  
    libQtCore.so.4()(64bit)  
    libQtDBus.so.4()(64bit)  
    libQtGui.so.4()(64bit)  
    libQtNetwork.so.4()(64bit)  
    libQtSvg.so.4()(64bit)  
    libQtXml.so.4()(64bit)  
    libc.so.6()(64bit)  
    libgcc_s.so.1()(64bit)  
    libkdecore.so.5()(64bit)  
    libkdeui.so.5()(64bit)  
    libkio.so.5()(64bit)  
    libm.so.6()(64bit)  
    libpthread.so.0()(64bit)  
    libstdc++.so.6()(64bit)  
    libstdc++.so.6(CXXABI_1.3)(64bit)  
    libtvdb.so.0()(64bit)  
    rtld(GNU_HASH)  



Provides
--------
libtvdb-debuginfo-0.3.0-3.fc19.x86_64.rpm:
    
    libtvdb-debuginfo = 0.3.0-3.fc19
    libtvdb-debuginfo(x86-64) = 0.3.0-3.fc19

libtvdb-devel-0.3.0-3.fc19.x86_64.rpm:
    
    libtvdb-devel = 0.3.0-3.fc19
    libtvdb-devel(x86-64) = 0.3.0-3.fc19

libtvdb-0.3.0-3.fc19.x86_64.rpm:
    
    libtvdb = 0.3.0-3.fc19
    libtvdb(x86-64) = 0.3.0-3.fc19
    libtvdb.so.0()(64bit)  



MD5-sum check
-------------
http://downloads.sourceforge.net/project/libtvdb/0.3/libtvdb-0.3.0.tar.bz2 :
  CHECKSUM(SHA256) this package     : cc766e3f02f5a66df23349d773e8c0151efe19d31ad51cbf87c06ea5c999aa81
  CHECKSUM(SHA256) upstream package : cc766e3f02f5a66df23349d773e8c0151efe19d31ad51cbf87c06ea5c999aa81


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 868717 -m fedora-devel-x86_64
Comment 8 Kevin Kofler 2012-11-25 13:50:25 EST
The "KDE e.V. as proxy" clause is only something KDE offers as an option to its developers, not a requirements, it's fine by KDE licensing policies to just use v2+, and it's not a problem to have some stuff under v2+ and other stuff under "v2 or v3 or whatever KDE e.V. approves" because there is a nonempty intersection: in fact, the former is a superset of the latter, so the latter is also the intersection.
Comment 9 Kevin Kofler 2012-11-25 13:51:38 EST
I suspect that the tvdb_export.h file is based on one of the many other *_export.h files in KDE code, it's standard boilerplate code, so it makes sense for it to be licensed as liberally as possible.
Comment 10 Daniel Vrátil 2012-11-26 07:48:19 EST
New Package SCM Request
=======================
Package Name: libtvdb
Short Description: Library to retrieve TV series information from web
Owners: dvratil
Branches: f17 f18
InitialCC:
Comment 11 Gwyn Ciesla 2012-11-26 08:08:16 EST
Git done (by process-git-requests).
Comment 12 Fedora Update System 2012-11-26 09:47:19 EST
libtvdb-0.3.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libtvdb-0.3.0-3.fc18
Comment 13 Fedora Update System 2012-11-26 10:03:51 EST
libtvdb-0.3.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libtvdb-0.3.0-3.fc17
Comment 14 Fedora Update System 2012-11-27 04:46:48 EST
libtvdb-0.3.0-3.fc18 has been pushed to the Fedora 18 testing repository.
Comment 15 Fedora Update System 2012-12-06 22:28:19 EST
libtvdb-0.3.0-3.fc17 has been pushed to the Fedora 17 stable repository.
Comment 16 Fedora Update System 2013-01-11 19:12:50 EST
libtvdb-0.3.0-3.fc18 has been pushed to the Fedora 18 stable repository.

Note You need to log in before you can comment on or make changes to this bug.