Bug 868777 - fail to install the system use vnc
fail to install the system use vnc
Status: CLOSED DUPLICATE of bug 832510
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
RejectedBlocker
: Reopened
: 868791 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 02:28 EDT by lnie
Modified: 2013-01-31 08:59 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-18.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-31 08:59:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (925 bytes, text/plain)
2012-10-22 03:35 EDT, Michal Kovarik
no flags Details
syslog (67.14 KB, text/plain)
2012-10-22 03:35 EDT, Michal Kovarik
no flags Details
I have test the TC7 on my system,it failed ,but on Michal's system it passed (925 bytes, text/x-log)
2012-11-05 22:10 EST, lnie
no flags Details
I have test the TC7 on my system,it failed ,but on Michal's system it passed (62.27 KB, application/octet-stream)
2012-11-05 22:10 EST, lnie
no flags Details

  None (edit)
Description lnie 2012-10-22 02:28:40 EDT
Description of problem:
Boot the installer with the following command-line options :
vnc vncpassword=12345678 (vnc)

Version-Release number of selected component (if applicable):
f18 x86-64 Beta Tc6
How reproducible:
100%
Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Kovarik 2012-10-22 03:34:37 EDT
I reproduced it on DVD installation Fedora-18 x86-64 Beta TC6.
Anaconda fell down with:
Could not initialize the VNC server: No IP addresses found.


on tty2:
ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:29:44:38 brd ff:ff:ff:ff:ff:ff
    inet 192.168.100.233/24 brd 192.168.100.255 scope global eth0
    inet6 fe80::5054:ff:fe29:4438/64 scope link 
       valid_lft forever preferred_lft forever

cat /proc/cmdline
initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2018-Beta-TC6\x20x86_64  vnc BOOT_IMAGE=vmlinuz
Comment 2 Michal Kovarik 2012-10-22 03:35:05 EDT
Created attachment 631306 [details]
anaconda.log
Comment 3 Michal Kovarik 2012-10-22 03:35:36 EDT
Created attachment 631307 [details]
syslog
Comment 4 Michal Kovarik 2012-10-22 07:09:37 EDT
It seems to me as race condition. It's only on media installation (dvd, netinst.iso).

How reproducible:
sometimes - depends on dhcp lease
Comment 5 Chris Lumens 2012-10-22 08:54:31 EDT
*** Bug 868791 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2012-10-22 11:32:38 EDT
This should be nominated as a Beta blocker, Alpha criteria say " The installer must be able to complete an installation using the text, graphical and VNC installation interfaces".
Comment 7 Adam Williamson 2012-10-23 21:53:29 EDT
Discussed at 2012-10-22 QA meeting acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-10-22/fedora-qa.2012-10-22-15.00.html . We agreed we need a few more details on this before deciding on blocker status. It would be useful to know if it affects only media-based installs or if it also affects PXE installs, as we suspect PXE installs may be the main users of the VNC feature. It would also help to know whether using a static IP address is usable as a workaround for this.
Comment 8 Michal Kovarik 2012-10-24 03:34:39 EDT
This issue affects only media-based installs with dhcp.
PXE installation and media-based installation with static network configuration works as expected.
Comment 9 Adam Williamson 2012-10-24 13:09:50 EDT
Discussed at the 2012-10-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-24/f18beta-blocker-review-5.2012-10-24-16.01.log.txt . With our current understanding of the issue, that it works with PXE and/or static networking, this is rejected as a Beta blocker: it violates the criterion only under certain conditions, and we believe the most likely use cases are covered. It can be re-proposed if more data emerges (tflink says he had trouble with a PXE/dhcp test, but it may not have been this precise bug).
Comment 10 Tao Wu 2012-11-05 01:18:20 EST
It works fine on TC7 32bit, I have just verified it.
Comment 11 lnie 2012-11-05 22:10:03 EST
Created attachment 639070 [details]
I have test the TC7 on my system,it failed ,but on Michal's system it passed
Comment 12 lnie 2012-11-05 22:10:47 EST
Created attachment 639071 [details]
I have test the TC7 on my system,it failed ,but on Michal's system it passed
Comment 13 Michal Kovarik 2012-11-06 01:59:02 EST
I've tried again with Fedora-18-Beta-TC7(DVD) in KVM. For first time it failed with this issue, for next time it worked fine.
Comment 14 lnie 2012-12-10 04:43:11 EST
 Still happens in the Fedora-18-Final-TC1 X86_64
Comment 15 Radek Vykydal 2012-12-10 09:40:01 EST
Yes, we race with slow dhcp NM's default auto connection is waiting for. Sending a patch to ML.
Comment 16 Fedora Update System 2012-12-11 19:54:47 EST
anaconda-18.37.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
Comment 17 Fedora Update System 2012-12-12 15:41:32 EST
Package anaconda-18.37.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-12-14 22:18:01 EST
anaconda-18.37.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Kamil Páral 2013-01-02 12:28:53 EST
Radek, can you look at bug 832510 comment 3? Maybe this is not fixed?
Comment 20 David Woodhouse 2013-01-02 14:26:23 EST
It looks like a call to network.wait_for_dhcp() was added. But that only waits for DHCP if the Ethernet driver has already loaded, and NM is *already* starting to connect. I suspect in my case it's all happening before NetworkManager notices the Ethernet device at all, so it's not in NM_STATE_CONNECTING.

The underlying problem is still there and not fixed at all. We've just changed the parameters of the race condition a bit. The real bug is that there's absolutely no reason to *abort* the installation when this happens. As far as I can tell, the only reason you need to know the IP address is to tell the user which address they can connect to. But the user could probably work that out some other way, if you can't manage it. You should still start the server listening on [::]. It's suboptimal if the user has to work out the IP address for themselves, but it's better than an outright failure. 

There is *no* situation in which the outright failure is better than printing "No network yet; VNC installation may not work..." and going ahead anyway, surely?

You could always add an asynchronous notification when an IP address *does* come along... but that's more work. Just avoiding the crash would be a good start.
Comment 21 Radek Vykydal 2013-01-31 08:59:12 EST

*** This bug has been marked as a duplicate of bug 832510 ***

Note You need to log in before you can comment on or make changes to this bug.