Bug 868852 - PRD32 - rhevm-manage-domains hardcodes the DC's address instead of using DNS lookups
PRD32 - rhevm-manage-domains hardcodes the DC's address instead of using DNS ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.2.0
Assigned To: Yair Zaslavsky
Ilanit Stein
infra
: ZStream
Depends On: 880352
Blocks: Simon-RFE-Tracker 907596 915537
  Show dependency treegraph
 
Reported: 2012-10-22 05:47 EDT by Dan Yasny
Modified: 2016-02-10 14:45 EST (History)
14 users (show)

See Also:
Fixed In Version: sf4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 907596 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10494 None None None Never

  None (edit)
Description Dan Yasny 2012-10-22 05:47:34 EDT
Description of problem:
When adding an IPA domain, DNS is only used for the IPA host discovery, after which we hardcode the address of the IPA server in krb5.conf (under /etc/ovirt-engine).

This means if the IPA host is down or moved, we will not be able to authenticate, even if there are available replicas serving IPA to the network. 

Version-Release number of selected component (if applicable):
rhevm-3.1.0-21.el6ev.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. install rhev-m
2. connect to an IPA domain
3. check /etc/ovirt-engine/krb5.conf under [realms]
  
Actual results:
hardcoded hostname:port for available DC

Expected results:
Should be using DNS SRV records instead of hardcoded DC names


Additional info:
Comment 1 Stephen Gordon 2012-10-22 11:16:43 EDT
Duplicate of Bug # 753620?
Comment 3 Dan Yasny 2012-10-23 10:37:22 EDT
(In reply to comment #1)
> Duplicate of Bug # 753620?

yup, looks like it
Comment 38 Itamar Heim 2013-06-11 04:40:19 EDT
3.2 has been released
Comment 39 Itamar Heim 2013-06-11 04:40:22 EDT
3.2 has been released
Comment 40 Itamar Heim 2013-06-11 04:40:22 EDT
3.2 has been released
Comment 41 Itamar Heim 2013-06-11 04:47:57 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.