Bug 868869 - Anaconda does not install any langpacks, dictionaries etc.
Anaconda does not install any langpacks, dictionaries etc.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: David Cantrell
Bill Nottingham
AcceptedNTH
:
: 868868 871334 (view as bug list)
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-22 06:38 EDT by Arkady L. Shane
Modified: 2014-03-16 23:32 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:35:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.program.log (39.66 KB, text/x-log)
2012-10-22 06:39 EDT, Arkady L. Shane
no flags Details
anaconda.packaging.log (226.21 KB, text/x-log)
2012-10-22 06:40 EDT, Arkady L. Shane
no flags Details
anaconda.log (11.41 KB, text/x-log)
2012-10-22 06:41 EDT, Arkady L. Shane
no flags Details
syslog (61.76 KB, application/octet-stream)
2012-10-22 06:42 EDT, Arkady L. Shane
no flags Details
anaconda.ifcfg.log (2.61 KB, text/x-log)
2012-10-22 06:44 EDT, Arkady L. Shane
no flags Details
anaconda.storage.log (80.94 KB, text/x-log)
2012-10-22 06:46 EDT, Arkady L. Shane
no flags Details
anaconda.xlog (15.20 KB, application/octet-stream)
2012-10-22 06:46 EDT, Arkady L. Shane
no flags Details

  None (edit)
Description Arkady L. Shane 2012-10-22 06:38:56 EDT
Fedora-18-Beta-TC6

I have installed Fedora in Russian language (also I've tried French). Selected libreoffice in "package selector", but in installed system there were not any langpacks and dictironaries, what must be installed for this language.

Such bug was in Fedora 17 (#834821 https://bugzilla.redhat.com/show_bug.cgi?id=834821).
Comment 1 Arkady L. Shane 2012-10-22 06:39:29 EDT
Created attachment 631390 [details]
anaconda.program.log
Comment 2 Arkady L. Shane 2012-10-22 06:40:31 EDT
Created attachment 631392 [details]
anaconda.packaging.log
Comment 3 Arkady L. Shane 2012-10-22 06:41:43 EDT
Created attachment 631393 [details]
anaconda.log
Comment 4 Arkady L. Shane 2012-10-22 06:42:40 EDT
Created attachment 631394 [details]
syslog
Comment 5 Arkady L. Shane 2012-10-22 06:44:15 EDT
Created attachment 631396 [details]
anaconda.ifcfg.log
Comment 6 Arkady L. Shane 2012-10-22 06:46:14 EDT
Created attachment 631398 [details]
anaconda.storage.log
Comment 7 Arkady L. Shane 2012-10-22 06:46:56 EDT
Created attachment 631399 [details]
anaconda.xlog
Comment 8 Bill Nottingham 2012-10-22 14:54:07 EDT
*** Bug 868868 has been marked as a duplicate of this bug. ***
Comment 9 Jesse Keating 2012-11-06 14:13:06 EST
Patch posted to enable use of yum-langpacks to get our conditional stuff installed.
Comment 10 Jesse Keating 2012-11-06 14:13:28 EST
*** Bug 871334 has been marked as a duplicate of this bug. ***
Comment 11 Jesse Keating 2012-11-06 14:22:53 EST
Nominating as a nice to have for Beta, given it's yum code we haven't previously used in Anaconda so we'd like as much testing as possible, and it's also pretty rude to not install translations et al for a user's specified language.
Comment 12 Adam Williamson 2012-11-06 14:36:51 EST
+1 NTH, obviously not installing translations and dictionaries for non-English languages sucks.
Comment 13 Tim Flink 2012-11-06 14:46:21 EST
+1 NTH as you would expect languages and dictionaries to be installed for non-English language installs.
Comment 14 Jaroslav Reznik 2012-11-06 14:46:55 EST
+1 NTH as you would expect languages and dictionaries to be installed for non-English language installs.
Comment 15 Tim Flink 2012-11-06 14:49:48 EST
That makes for +3 NTH, moving to accepted
Comment 16 Fedora Update System 2012-11-06 21:09:05 EST
lorax-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.22-1.fc18
Comment 17 Fedora Update System 2012-11-06 21:09:15 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 18 Fedora Update System 2012-11-07 13:46:33 EST
Package anaconda-18.26-1.fc18, lorax-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.26-1.fc18 lorax-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17714/lorax-18.22-1.fc18,anaconda-18.26-1.fc18
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-11-07 22:23:33 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 20 Adam Williamson 2012-11-08 04:35:24 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.