Bug 868948 - SELinux is preventing rpc.idmapd from 'getattr' accesses on the file /etc/samba/smb.conf.
SELinux is preventing rpc.idmapd from 'getattr' accesses on the file /etc/sam...
Status: CLOSED DUPLICATE of bug 868946
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:27257ed1a937d46513c12eb7d3a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 10:17 EDT by Mahmoud youssif
Modified: 2012-10-23 08:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 08:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mahmoud youssif 2012-10-22 10:17:11 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.11-1.fc16.i686
time:           Mon 22 Oct 2012 04:14:06 PM EET

description:
:SELinux is preventing rpc.idmapd from 'getattr' accesses on the file /etc/samba/smb.conf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rpc.idmapd should be allowed getattr access on the smb.conf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rpc.idmapd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rpcd_t:s0
:Target Context                system_u:object_r:samba_etc_t:s0
:Target Objects                /etc/samba/smb.conf [ file ]
:Source                        rpc.idmapd
:Source Path                   rpc.idmapd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           nfs-utils-1.2.5-8.fc16.i686
:Target RPM Packages           samba-common-3.6.6-88.fc16.i686
:Policy RPM                    selinux-policy-3.10.0-91.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.11-1.fc16.i686 #1
:                              SMP Sun Sep 16 14:41:18 UTC 2012 i686 i686
:Alert Count                   7
:First Seen                    Sun 20 May 2012 11:35:17 AM EET
:Last Seen                     Sun 14 Oct 2012 01:15:19 PM EET
:Local ID                      36fa81ec-e345-4bfa-9e0b-f2541232d0a4
:
:Raw Audit Messages
:type=AVC msg=audit(1350213319.631:29): avc:  denied  { getattr } for  pid=1142 comm="rpc.idmapd" path="/etc/samba/smb.conf" dev="sda3" ino=3680093 scontext=system_u:system_r:rpcd_t:s0 tcontext=system_u:object_r:samba_etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1350213319.631:29): arch=i386 syscall=stat64 success=no exit=EACCES a0=b7b751a0 a1=bffe7740 a2=b76c1ff4 a3=b73ef6a4 items=0 ppid=1 pid=1142 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rpc.idmapd exe=/usr/sbin/rpc.idmapd subj=system_u:system_r:rpcd_t:s0 key=(null)
:
:Hash: rpc.idmapd,rpcd_t,samba_etc_t,file,getattr
:
:audit2allow
:
:#============= rpcd_t ==============
:allow rpcd_t samba_etc_t:file getattr;
:
:audit2allow -R
:
:#============= rpcd_t ==============
:allow rpcd_t samba_etc_t:file getattr;
:
Comment 1 Miroslav Grepl 2012-10-23 08:34:12 EDT

*** This bug has been marked as a duplicate of bug 868946 ***

Note You need to log in before you can comment on or make changes to this bug.