Bug 868971 - TCMS is sending unwanted e-mails about runs
TCMS is sending unwanted e-mails about runs
Status: CLOSED WONTFIX
Product: TCMS
Classification: Other
Component: Web UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Zheng Liu
tools-bugs
:
: 977808 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 11:26 EDT by Zbysek MRAZ
Modified: 2016-06-12 21:32 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-12 21:32:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbysek MRAZ 2012-10-22 11:26:52 EDT
Description of problem:
If you are either run creator, tester or assignee of any from the case in the plan, TCMS is sending the e-mail saying that the run has been created for you.

The notifications in the plan are set to noone, triggering on anything, but all the people are still receiving the e-mail.

The notification about creating test run will come when you create, change notes and even when you are changing to "finished" state.
Comment 1 yawei Li 2012-10-30 05:11:59 EDT
Notification functionality is planned to be redesigned in TCMS 4.0. 
May I have your more and detailed requirements on notification? What kinds of info your need on test plan, test run and test case notification?
Comment 2 Karel Srot 2012-11-02 07:07:19 EDT
TCMS test PLAN has following items:

Notification Trigger 	
* when plan is updated
* when plan is deleted
* when cases of a plan are updated

Please add a another trigger "when test RUN is created/closed" (disabled by default). Currently I am receiving A LOT of emails about new test runs just because other people that have one of my test cases in their plan (e.g. because of integration testing) created/completed a new run.
I am spammed with so many notification that I am not willing/able to filter notifications that are actually important for me.


2. Test run notification are almost useless. Today I received several mails with subject "Test run XY has been updated". But the body of the mail is quite long and contains several details about the run so I cannot recognize what the actual update is.

E.g. What happened here was that the Run was finished. But from the mail body (below) It is not easy to identify what is the actual reason for this notification. Instead, the short message such as "Test run XY was completed" should be at the beginning of the mail body.



Test run 49426 has been updated for you.

### Links ###
Test run: http://tcms.engineering.redhat.com/run/49426/


### Basic run information ###
Summary: BaseOS / Tier 1 / Security / RHEL5.9 on RHEL5.9-Server-20121025.3

Managed: zmraz.
Default tester: zmraz.

Product: Red Hat Enterprise Linux 5
Product version: 5.9
Build: RHEL5.9-Server-20121025.3

Estimated time: 0:00:00

Notes:
%beaker-jobwatch%
2012-10-27 03:26:20.626101
TR#49426 - BaseOS / Tier 1 / Security / RHEL5.9 on RHEL5.9-Server-20121025.3 - singlehost
Broken: 0
Running:   0/5
Completed: 5/5
        TJ#323368
https://beaker.engineering.redhat.com/matrix/?toggle_nacks_on=on&job_ids=323368
%beaker-jobwatch%

### Test plan information ###
Test Plan: BaseOS / Tier 1 / Security / RHEL5.9
Comment 3 yawei Li 2012-11-13 01:14:54 EST
Thanks for your detailed requirements, they are reasonable. The notification mechanism will be improved in tcms 4.0.
If you have any more requirements, please feel free to add more.
Comment 4 Karel Srot 2013-06-25 07:38:31 EDT
Dalibor Pospíšil 2013-06-25 07:21:59 EDT

Every touch to the TCMS run (write to the note the same content) causes notification of all assignees in the run. This should be configurable in user preferences. It should be possible to specify verbosity level.

Most people would be happy with notification in case their case run has changed status and/or notes/comments.

There could be also a possibility to concentrate those infos and send it in user defined frequency (5m, 15, 1h, 3h, 12h, 24h, ...).

Also there should be a way to disable notifications of people who left the company.
Comment 5 Karel Srot 2013-06-25 07:39:20 EDT
*** Bug 977808 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.