Bug 869008 - mapping for productId 195 "Red Hat Developer Toolset (for RHEL for IBM POWER)" is missing
mapping for productId 195 "Red Hat Developer Toolset (for RHEL for IBM POWER)...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
John Sefler
:
Depends On:
Blocks: rhsm-rhel510 875802
  Show dependency treegraph
 
Reported: 2012-10-22 14:28 EDT by John Sefler
Modified: 2013-05-10 15:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 875802 (view as bug list)
Environment:
Last Closed: 2013-05-10 15:42:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-10-22 14:28:49 EDT
Description of problem:
product cert mapping for "Red Hat Developer Toolset (for RHEL for IBM POWER)" channels "rhel-ppc-server-dts-5-*" to 195.pem are missing from /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt

Need a new build of the subscription-manager-migration-data.


Version-Release number of selected component (if applicable):
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.2.7-1.el5


How reproducible:


Steps to Reproduce:
[root@rhsm-accept-rhel5 ~]# grep rhel-ppc-server-dts /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
[root@rhsm-accept-rhel5 ~]#

^^^ Expected to find mappings for RHN Channels these channels:
             "rhel-ppc-server-dts-5-beta", 
             "rhel-ppc-server-dts-5-beta-debuginfo",
Comment 1 RHEL Product and Program Management 2012-10-22 14:38:37 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2012-10-30 02:15:08 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Alex Wood 2013-05-10 11:00:25 EDT
This bug appears due to a mismatch in architecture names between the certificate and what is in product_baseline.json.

In product_baseline.json:

"Name": "Red Hat Developer Toolset (for RHEL for IBM POWER)",
"Product ID": "195",
"RHN Channels": [
   "rhel-ppc-server-dts-5-beta",
   "rhel-ppc-server-dts-5-beta-debuginfo",
   "rhel-ppc64-server-dts-6-beta",
   "rhel-ppc64-server-dts-6-beta-debuginfo"
]

And in the product_ids directory:

% find -name '*195.pem'
./dts-1.1/Server-DTS-ppc64-c65aad65dfe2-195.pem

Note that the channel name for RHEL 5 has the "ppc" architecture and that the certificate has the "ppc64" architecture.  This mismatch causes the script that generates the channel-cert-mapping.txt file to miss finding the certificate when it searches.  The script is actually performing a glob search for "*ppc-*-195*.pem" which doesn't match the actual certificate name.
Comment 4 Dennis Gregorovic 2013-05-10 11:41:14 EDT
Let's not worry about this bug... DTS for ppc was added at DTS 1.1 Beta but then dropped before 1.1 GA.  I'll work on removing the channels from RHN.
Comment 5 Bryan Kearney 2013-05-10 15:42:24 EDT
Per comments from Dennis, Closing this out.

Note You need to log in before you can comment on or make changes to this bug.