This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 869093 - SystemError: (32, 'umount: /run/install/isodir: target is busy.\n (In some cases useful info about processes that use\n the device is found by lsof(8) or fuser(1))')
SystemError: (32, 'umount: /run/install/isodir: target is busy.\n (In ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:9793dbb2b61082f9bbc0e65f459...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 22:36 EDT by Reartes Guillermo
Modified: 2013-05-10 01:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-18.23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 01:35:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (207.24 KB, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: storage.log (72.44 KB, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: environ (780 bytes, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (4.04 KB, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: syslog (62.30 KB, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-22 22:37 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-22 22:38 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-22 22:38 EDT, Reartes Guillermo
no flags Details
File: program.log (34.56 KB, text/plain)
2012-10-22 22:38 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-22 22:36:47 EDT
Description of problem:
i changed INSTALLATION SOURCE to ISO IMAGE, selected the other disk, and manually selected the . directory (or something like that)

Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/isys/__init__.py", line 152, in umount
:    rc = _isys.umount(what)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 656, in unmount
:    rc = isys.umount(self._mountpoint, removeDir = False)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 223, in run
:    dev.format.unmount()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 802, in on_chooser_clicked
:    f = dialog.run(self._get_selected_partition())
:SystemError: (32, 'umount: /run/install/isodir: target is busy.\n        (In some cases useful info about processes that use\n         the device is found by lsof(8) or fuser(1))')
Comment 1 Reartes Guillermo 2012-10-22 22:37:01 EDT
Created attachment 631829 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-22 22:37:13 EDT
Created attachment 631830 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-22 22:37:16 EDT
Created attachment 631831 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-22 22:37:18 EDT
Created attachment 631832 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-22 22:37:43 EDT
Created attachment 631833 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-22 22:37:46 EDT
Created attachment 631834 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-22 22:37:48 EDT
Created attachment 631835 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-22 22:37:50 EDT
Created attachment 631836 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-22 22:37:54 EDT
Created attachment 631837 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-22 22:37:56 EDT
Created attachment 631838 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-22 22:37:58 EDT
Created attachment 631839 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-22 22:38:00 EDT
Created attachment 631840 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-22 22:38:02 EDT
Created attachment 631841 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-22 22:38:05 EDT
Created attachment 631842 [details]
File: program.log
Comment 15 Jesse Keating 2012-11-01 18:46:05 EDT
I think this will be fixed in the next build of anaconda.  Please retest the next Beta Test Compose.
Comment 16 Adam Williamson 2012-11-23 00:49:02 EST
Reartes, can you re-test as requested?
Comment 17 Reartes Guillermo 2012-11-25 12:49:33 EST
I tested it (f18b RC1), but i could not reproduce it because i can no longer choose the iso installation method. Then i remembered what you said on RHBZ 849482 Comment #8.

Then i tried on a guest with two disks, and i used manual partitioning using only the first one. But that was not enough and the iso installation source was not there. 

I also tried another guest with many disks and F17, also choosing only one disks and doing manual partitioning on it. I also could not select iso as an installation source.

So, since i cannot select iso image as an installation source, i also cannot reproduce the issue. If it is normal or expected to not to be able to use the iso installation source in such scenarios, then this bug-report can be closed.
Comment 19 Adam Williamson 2013-05-10 01:25:11 EDT
Tested with F19 Beta TC3. Like Reartes, I can't make the ISO file source option appear any more, even when installing to a system with two disks, selecting only one of them as an install target, and the other one contains an ISO. That seems like a worse bug. I'll file it.
Comment 20 Adam Williamson 2013-05-10 01:35:08 EDT
Okay, the ISO option shows up if you don't go to Installation Destination first. I tried various ways of making this bug happen, but couldn't. I'll close this; Reartes, if you can still reproduce it, please re-open. thanks!
Comment 21 Adam Williamson 2013-05-10 01:39:21 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=961616 for the bug of the ISO file option disappearing from Installation Source if you go to Installation Destination first.
Comment 22 Adam Williamson 2013-05-10 01:43:49 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=961618 is another bug I hit while fiddling with this.

Note You need to log in before you can comment on or make changes to this bug.