Bug 869275 - Creating engine db from template1 doesn't work due to wrong template1 encoding
Creating engine db from template1 doesn't work due to wrong template1 encoding
Status: CLOSED DUPLICATE of bug 870056
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.1 RC
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ohad Basan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 09:07 EDT by Ohad Basan
Modified: 2014-10-30 18:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 11:19:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2012-10-23 09:07:53 EDT
Description of problem:
on fedora 18 + postrgres 9.2
creating engine db using create_db -E utf8 fails since we base on pg template1 which has a default encoding of ASCII by default.


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.install fedora18+ovirt engine
2.run setup and go through all the stages.
3.
  
Actual results:
setup fails due to incompatibility between the template's encoding and the new db's encoding

Expected results:
db created successfully. 

Additional info:
Comment 1 Ohad Basan 2012-10-23 09:10:32 EDT
patch posted upstream:

http://gerrit.ovirt.org/#/c/8744/
Comment 2 Eli Mesika 2012-10-25 11:19:52 EDT

*** This bug has been marked as a duplicate of bug 870056 ***

Note You need to log in before you can comment on or make changes to this bug.