Bug 870056 - altering template1 encoding on createdb
altering template1 encoding on createdb
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.1 RC
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.2
Assigned To: Ohad Basan
infra
:
: 869275 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 09:42 EDT by Eli Mesika
Modified: 2014-10-30 18:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:47:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eli Mesika 2012-10-25 09:42:02 EDT
Description of problem:
backup.sh and database scripts use template1 instead of template0

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run create_db.sh or engine-db-install.sh
2.psql -U postgres -l 
3.look for the locale info
  
Actual results:
Database creation scripts are using template1 database, this may result in a locale conflict when we are using UTF8 and the template 1 is configured with ASCII.

Expected results:
All database creation and handling scripts should use template 0

Additional info:
Comment 1 Eli Mesika 2012-10-25 11:18:20 EDT
http://gerrit.ovirt.org/#/c/8823/
Comment 2 Eli Mesika 2012-10-25 11:19:52 EDT
*** Bug 869275 has been marked as a duplicate of this bug. ***
Comment 4 Eli Mesika 2012-10-28 04:25:30 EDT
fixed in commit: 9538658
Comment 5 Ohad Basan 2012-10-30 18:05:49 EDT
reopening the bug
looks like the problem when using template0 is that it is blocks connections so we won't be able to install postgres extensions.
we have no choice but to use template1 and change the encoding.
Comment 6 Ohad Basan 2012-10-30 18:10:23 EDT
Patch posted upstream

http://gerrit.ovirt.org/8936
Comment 7 Juan Hernández 2012-10-31 05:39:45 EDT
This is an alternative to the patch in comment #6. It makes it possible to use the template0 database as the extensions are created on the engine database once it is created:

http://gerrit.ovirt.org/8926

Please review and let me know what you think.
Comment 8 Ohad Basan 2012-11-01 11:29:53 EDT
An alternative patch to the patch in comment #7 is here:

http://gerrit.ovirt.org/#/c/8955/
Comment 9 Eli Mesika 2012-11-06 17:20:51 EST
fixed in commit: 6891171
Comment 10 Itamar Heim 2013-01-16 11:08:31 EST
3.2 beta built, moving to ON_QA status to allow testing

Note You need to log in before you can comment on or make changes to this bug.