Bug 869381 - ValueError: ('invalid size specification', '-1.000000 MB')
ValueError: ('invalid size specification', '-1.000000 MB')
Status: CLOSED DUPLICATE of bug 864766
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:355f39b811d57b0e0641583167e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 14:15 EDT by Reartes Guillermo
Modified: 2012-11-05 15:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 15:09:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (433.74 KB, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: storage.log (241.47 KB, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: environ (780 bytes, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (44.20 KB, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: syslog (61.78 KB, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-23 14:15 EDT, Reartes Guillermo
no flags Details
File: program.log (45.37 KB, text/plain)
2012-10-23 14:16 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-23 14:15:07 EDT
Description of problem:
i switched a partition to xfs and encrypt

Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 79, in _parseSpec
:    raise ValueError("invalid size specification", spec)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 137, in __new__
:    self = Decimal.__new__(cls, value=_parseSpec(spec))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1131, in _save_right_side
:    % str(Size(spec="%f MB" % device.size)).upper())
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1561, in on_finish_clicked
:    self._save_right_side(self._current_selector)
:ValueError: ('invalid size specification', '-1.000000 MB')
Comment 1 Reartes Guillermo 2012-10-23 14:15:21 EDT
Created attachment 632257 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-23 14:15:24 EDT
Created attachment 632258 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-23 14:15:26 EDT
Created attachment 632259 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-23 14:15:28 EDT
Created attachment 632260 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-23 14:15:36 EDT
Created attachment 632261 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-23 14:15:39 EDT
Created attachment 632262 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-23 14:15:41 EDT
Created attachment 632263 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-23 14:15:44 EDT
Created attachment 632264 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-23 14:15:47 EDT
Created attachment 632265 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-23 14:15:50 EDT
Created attachment 632266 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-23 14:15:52 EDT
Created attachment 632267 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-23 14:15:54 EDT
Created attachment 632268 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-23 14:15:56 EDT
Created attachment 632269 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-23 14:16:00 EDT
Created attachment 632270 [details]
File: program.log
Comment 15 Adam Williamson 2012-11-05 15:09:31 EST
dlehman believes all these '-1.000000 MB' bugs are the same.

*** This bug has been marked as a duplicate of bug 864766 ***

Note You need to log in before you can comment on or make changes to this bug.