Bug 869402 - thin pool lvconvert man page example is missing the ''--poolmetadata" flag
Summary: thin pool lvconvert man page example is missing the ''--poolmetadata" flag
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Zdenek Kabelac
QA Contact: Cluster QE
URL:
Whiteboard:
: 869417 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-23 19:26 UTC by Corey Marthaler
Modified: 2013-02-21 08:14 UTC (History)
10 users (show)

Fixed In Version: lvm2-2.02.98-4.el6
Doc Type: Enhancement
Doc Text:
Man page for lvconvert has been enhanced with new supported options for conversion of existing volumes into a thin pool.
Clone Of:
Environment:
Last Closed: 2013-02-21 08:14:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0501 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2013-02-20 21:30:45 UTC

Description Corey Marthaler 2012-10-23 19:26:20 UTC
Description of problem:
lvconvert --thinpool  ThinPoolLogicalVolume{Name|Path}  [-c|--chunksize  ChunkSize]  [-h|-?|--help]  [-v|--verbose]  [--version]  [-Z|--zero  {y|n}]  ThinMetadataLogicalVol-
       ume{Name|Path}


* should be *


lvconvert --thinpool  ThinPoolLogicalVolume{Name|Path}  [-c|--chunksize  ChunkSize]  [-h|-?|--help]  [-v|--verbose]  [--version]  [-Z|--zero  {y|n}]  --poolmetadata  ThinMetadataLogicalVol-ume{Name|Path}



Version-Release number of selected component (if applicable):
2.6.32-330.el6.x86_64

lvm2-2.02.98-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
lvm2-libs-2.02.98-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
lvm2-cluster-2.02.98-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
udev-147-2.43.el6    BUILT: Thu Oct 11 05:59:38 CDT 2012
device-mapper-1.02.77-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
device-mapper-libs-1.02.77-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
device-mapper-event-1.02.77-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
device-mapper-event-libs-1.02.77-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
cmirror-2.02.98-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012

Comment 2 Zdenek Kabelac 2012-10-24 08:39:22 UTC
Yes, also --discards  option is missing there, will be updated with few more man page corrections.

Comment 4 Zdenek Kabelac 2012-11-27 19:38:59 UTC
Man page has been updated together with related fixes for lvconvert.

https://www.redhat.com/archives/lvm-devel/2012-November/msg00033.html

Also other patches are needed to provide documented functionality.

Comment 5 Zdenek Kabelac 2012-11-27 19:41:08 UTC
*** Bug 869417 has been marked as a duplicate of this bug. ***

Comment 7 Corey Marthaler 2013-01-03 00:29:29 UTC
Fix verified in the latest rpms, now contains both --poolmetadata and --discards.

       lvconvert  --thinpool ThinPoolLogicalVolume{Name|Path} [-c|--chunksize ChunkSize[bBsSkKmMgG]] [--discards {ignore|nopassdown|passdown}] [[--poolmetadata ThinPoolMetadataLogicalVolume{Name|Path}]
       | [--poolmetadatasize  ThinPoolMetadataSize[bBsSkKmMgG]]


2.6.32-348.el6.x86_64
lvm2-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
lvm2-libs-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
lvm2-cluster-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
udev-147-2.43.el6    BUILT: Thu Oct 11 05:59:38 CDT 2012
device-mapper-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-libs-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-event-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
device-mapper-event-libs-1.02.77-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012
cmirror-2.02.98-6.el6    BUILT: Thu Dec 20 07:00:04 CST 2012

Comment 8 errata-xmlrpc 2013-02-21 08:14:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html


Note You need to log in before you can comment on or make changes to this bug.