Bug 869417 - is a --poolmetadata volume option required when converting a linear to pool
is a --poolmetadata volume option required when converting a linear to pool
Status: CLOSED DUPLICATE of bug 869402
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.4
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Zdenek Kabelac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 16:01 EDT by Corey Marthaler
Modified: 2012-11-27 14:41 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 14:41:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2012-10-23 16:01:06 EDT
Description of problem:
[root@taft-04 ~]# pvscan
  PV /dev/sdb1   VG VG          lvm2 [135.66 GiB / 135.66 GiB free]
  PV /dev/sdc1   VG VG          lvm2 [135.66 GiB / 135.66 GiB free]
  PV /dev/sdd1   VG VG          lvm2 [135.66 GiB / 135.66 GiB free]

[root@taft-04 ~]# lvcreate -n lv1 -L 100M VG
  Logical volume "lv1" created
[root@taft-04 ~]# lvcreate -n lv2 -L 100M VG
  Logical volume "lv2" created

[root@taft-04 ~]# lvs -a -o +devices
  LV      VG    Attr      LSize   Pool Data%  Devices         
  lv1     VG    -wi-a---- 100.00m             /dev/sdb1(0)    
  lv2     VG    -wi-a---- 100.00m             /dev/sdb1(25)   

[root@taft-04 ~]#  lvconvert --thinpool VG/lv1
  Uknown metadata.

### Is --poolmetadata required?? If so can we enhance this error message to include the need for '--poolmetadata' to be present in the cmdline. I'm not sure since it wasn't required in the previous build (however that build resulted in bug 858874)

[root@taft-04 ~]#  lvconvert --thinpool VG/lv1 --poolmetadata VG/lv2
  Converted VG/lv1 to thin pool.

[root@taft-04 ~]# lvs -a -o +devices
  LV          VG    Attr      LSize   Pool Data%  Devices         
  lv1         VG    twi-a-t-- 100.00m        0.00 lv1_tdata(0)    
  [lv1_tdata] VG    Twi-aot-- 100.00m             /dev/sdb1(0)    
  [lv1_tmeta] VG    ewi-aot-- 100.00m             /dev/sdb1(25)   

[root@taft-04 ~]# lvcreate --virtualsize 500M --thinpool VG/lv1 -n virtvol1
  Logical volume "virtvol1" created
[root@taft-04 ~]# lvcreate --virtualsize 500M --thinpool VG/lv1 -n virtvol2
  Logical volume "virtvol2" created
[root@taft-04 ~]# lvs -a -o +devices
  LV          VG    Attr      LSize   Pool Data%  Devices         
  lv1         VG    twi-a-t-- 100.00m        0.12 lv1_tdata(0)    
  [lv1_tdata] VG    Twi-aot-- 100.00m             /dev/sdb1(0)    
  [lv1_tmeta] VG    ewi-aot-- 100.00m             /dev/sdb1(25)   
  virtvol1    VG    Vwi-a-t-- 500.00m lv1    0.01                 
  virtvol2    VG    Vwi-a-t-- 500.00m lv1    0.01                 


Version-Release number of selected component (if applicable):
2.6.32-330.el6.x86_64

lvm2-2.02.98-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
lvm2-libs-2.02.98-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
lvm2-cluster-2.02.98-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
udev-147-2.43.el6    BUILT: Thu Oct 11 05:59:38 CDT 2012
device-mapper-1.02.77-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
device-mapper-libs-1.02.77-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
device-mapper-event-1.02.77-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
device-mapper-event-libs-1.02.77-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
cmirror-2.02.98-2.el6    BUILT: Tue Oct 16 05:15:59 CDT 2012
Comment 1 Zdenek Kabelac 2012-10-24 04:43:52 EDT
Yes, for this moment the only supported conversion is  with giving thinpool LV device name and poolmetadata  LVM device name.

Probably better explanatory message could be added to avoid confusion.

lvconvert will have more capabilities in the next version.
Comment 4 Zdenek Kabelac 2012-11-27 14:41:08 EST

*** This bug has been marked as a duplicate of bug 869402 ***

Note You need to log in before you can comment on or make changes to this bug.