Bug 869513 - KDump SSH can be set and saved without providing a correct password
KDump SSH can be set and saved without providing a correct password
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 03:00 EDT by Meng Liang
Modified: 2013-02-28 11:42 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-13.el6
Doc Type: Bug Fix
Doc Text:
Previously, SSH could be configured for kdump when an incorrect password was provided. kdump now verifies that the SSH connection is set up successfully before finishing configuration. If a wrong password is provided, an error message appears explaining that kdump configuration failed because the location was unreachable.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:42:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
password pop-up windows (5.60 KB, image/png)
2012-11-29 01:52 EST, cshao
no flags Details
press ctrl+c (12.68 KB, image/png)
2012-11-29 01:53 EST, cshao
no flags Details

  None (edit)
Description Meng Liang 2012-10-24 03:00:54 EDT
Description of problem:
On the Kernel Dump page, select SSH with a valid SSH location.
Giving a wrong password/Not providing password under the command line and enter 'Ctrl+c' and 'exit', user will be lead to the login page.
Login fail, though correct password was provided.
Reboot the system and login, on the Kdump page, it shows as SSH configured successfully with the SSH location info.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible:
Always

Steps to Reproduce:
1. Install rhevh and set network
2. On the Kernel Dump page, select SSH with a valid SSH location.
3. Giving a wrong password/Not providing password under the command line and enter 'Ctrl+c' and 'exit'
  
Actual results:
User was lead to the login page.
Login failed, though correct password was provided.
Rebooted the system and login, on the Kdump page, it shown as SSH has been configured successfully with the SSH location info.

Expected results:
Provide a better way to lead user back to the configuration page
SSH should not be set successfully until correct password is provided

Additional info:
No such issue in rhevh-6.3-20121023.0.el6_3, so it is a regression bug.
Comment 7 cshao 2012-11-29 01:52:27 EST
Created attachment 654009 [details]
password pop-up windows
Comment 8 cshao 2012-11-29 01:53:10 EST
Created attachment 654010 [details]
press ctrl+c
Comment 22 Fabian Deutsch 2013-01-03 04:33:45 EST
http://gerrit.ovirt.org/#/c/10064/

Tested as follows:
1. Install with patch applied
2. Configure network with dhcp
3. Configure KDUMP with valid ssh url
4. Hit Apply
5. Password prompt appears: Press ctrl+c twice
6. TUI appears again showing empty fields and /etc/kdump.conf/.old don't exist

Working on this uncovered bug 891558.
Comment 27 errata-xmlrpc 2013-02-28 11:42:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.