Bug 869842 - installer incorrectly claims there is plenty of free space to install
installer incorrectly claims there is plenty of free space to install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:5323d239335f1c49bd25c2dc906...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 19:24 EDT by Chris Murphy
Modified: 2013-05-09 21:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 869839
Environment:
Last Closed: 2013-05-09 21:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2012-10-24 19:24:03 EDT
+++ This bug was initially created as a clone of Bug #869839 +++

Immediately prior to Bug 869839 I get a bogus message in Storage > Installation Destiantion, disk selection. Fails to show the reclaim space dialog. Instead shows the "You're all set!" message.

1. Select the two disks (which contain a prior successful btrfs raid0 install, which is bootable)
2. Click continue.

Result:
Dialog appears "Installation Options: You have plenty of space to installa Fedora, so we can automatically configure the rest of the installation for you....." etc.

Expected:
I'm expecting the Reclaim space dialog here. The entirety of both disks selected are completely consumed by the previous btrfs installation. Is it going to automatically shrink? How?

Ahh, indeed if I say continue with automatic partitioning is says in Hub "Error checking storage configuration" when I click to get more information "not enough free space on disks". So this is a bug. The same logs filed with 869839 apply.
Comment 1 David Lehman 2012-10-25 10:28:33 EDT
It looks like we consider the space required for the software install but we do not also consider the minimum space required by the automatic partiitoning layout. This is one of those cases where there is 4GB free on disk but the swap request alone pretty much takes all of that space.
Comment 2 David Lehman 2012-11-08 20:56:57 EST
The case of large automatic swap request invalidating the space check will be fixed in anaconda-18.28-1.
Comment 3 Adam Williamson 2012-11-23 01:06:21 EST
Chris: can you confirm this is fixed in TC9 or RC1?
Comment 4 Adam Williamson 2013-05-09 21:56:14 EDT
Chris never got back, and F19 is pretty explicit that it's checking the amount of swap space needed. Let's close this out.

Note You need to log in before you can comment on or make changes to this bug.