Bug 869839 - AttributeError: 'NoneType' object has no attribute 'format'
AttributeError: 'NoneType' object has no attribute 'format'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:5323d239335f1c49bd25c2dc906...
:
: 873332 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-24 19:07 EDT by Chris Murphy
Modified: 2012-11-08 04:36 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 869842 (view as bug list)
Environment:
Last Closed: 2012-11-08 04:36:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (360.36 KB, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: environ (885 bytes, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: type (9 bytes, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: storage.log (156.82 KB, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: version (2 bytes, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: program.log (45.62 KB, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: product (6 bytes, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: anaconda.log (9.87 KB, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: cmdline_file (162 bytes, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: release (33 bytes, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details
File: messages (113.10 KB, text/plain)
2012-10-24 19:07 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-10-24 19:07:19 EDT
Description of problem:
1. Started with a previously successful 2-disk btrfs raid0 installation.
2. Chose both of those same disks for reinstallation.
3. Manual Partitioning, delete swap partition.
4. Dialog appears asking if I want to delete all other partitions in (group?) Unknown.
5. Confirmed this.
Crash.


Version-Release number of selected component:
anaconda-18.19-1.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1670, in _destroy_device
:    if device.type == "partition" and device.disk.format.exists:
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1699, in _destroy_device
:    self._destroy_device(parent)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1760, in on_remove_clicked
:    self._destroy_device(dev)
:AttributeError: 'NoneType' object has no attribute 'format'
Comment 1 Chris Murphy 2012-10-24 19:07:22 EDT
Created attachment 633091 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2012-10-24 19:07:24 EDT
Created attachment 633092 [details]
File: environ
Comment 3 Chris Murphy 2012-10-24 19:07:26 EDT
Created attachment 633093 [details]
File: type
Comment 4 Chris Murphy 2012-10-24 19:07:27 EDT
Created attachment 633094 [details]
File: ifcfg.log
Comment 5 Chris Murphy 2012-10-24 19:07:29 EDT
Created attachment 633095 [details]
File: storage.log
Comment 6 Chris Murphy 2012-10-24 19:07:30 EDT
Created attachment 633096 [details]
File: version
Comment 7 Chris Murphy 2012-10-24 19:07:32 EDT
Created attachment 633097 [details]
File: program.log
Comment 8 Chris Murphy 2012-10-24 19:07:34 EDT
Created attachment 633098 [details]
File: product
Comment 9 Chris Murphy 2012-10-24 19:07:35 EDT
Created attachment 633099 [details]
File: anaconda.log
Comment 10 Chris Murphy 2012-10-24 19:07:37 EDT
Created attachment 633100 [details]
File: hashmarkername
Comment 11 Chris Murphy 2012-10-24 19:07:38 EDT
Created attachment 633101 [details]
File: cmdline_file
Comment 12 Chris Murphy 2012-10-24 19:07:40 EDT
Created attachment 633102 [details]
File: release
Comment 13 Chris Murphy 2012-10-24 19:07:42 EDT
Created attachment 633103 [details]
File: messages
Comment 14 Chris Murphy 2012-10-24 19:25:42 EDT
Immediately preceding this bug, is Bug 869842, in which the installer has incorrectly determined there is enough free space for automatic partitioning. So I cloned this bug to make that one, and I'm cross referencing since it seems they may be related.
Comment 15 Chris Murphy 2012-10-24 19:36:45 EDT
Propose as beta blocker, reason beta criterion 10: custom partitioning mode must be capable of destroying these partitions; and even if invalid the installer should not crash.
Comment 16 David Lehman 2012-10-25 10:52:02 EDT
This is caused by the same underlying problem as bug 866101, but it reveals a missing check.
Comment 17 Adam Williamson 2012-10-25 14:40:34 EDT
we're still fiddling with the criteria, but in general I'm broadly +1 to taking outright crashes for sane operations in custom part as blockers, so +1 blocker.
Comment 18 Adam Williamson 2012-10-29 14:57:56 EDT
Discussed at 2012-10-29 QA meeting acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-10-29/fedora-qa.2012-10-29-15.00.html . We agreed that since this seems to impact only specific btrfs configurations it's not broad enough in impact to constitute a blocker. Note that the criteria for partitioning are still in revision so we didn't strictly consider the bug WRT the criteria. We felt the conditions needed to hit this bug are likely to be fairly rare and there are obvious workarounds (remove the partitions with some other tool).

it is accepted as NTH, though, as it may affect testability of the Beta.

Proposing as a Final blocker under the more generous Final partitioning criterion.
Comment 19 Fedora Update System 2012-10-31 22:50:52 EDT
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18
Comment 20 Fedora Update System 2012-11-01 14:26:17 EDT
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2012-11-02 00:05:21 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 22 Fedora Update System 2012-11-02 21:04:54 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 23 Brian Lane 2012-11-05 14:05:42 EST
*** Bug 873332 has been marked as a duplicate of this bug. ***
Comment 24 Fedora Update System 2012-11-05 20:40:03 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 25 Fedora Update System 2012-11-06 21:11:59 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 26 Adam Williamson 2012-11-08 04:36:15 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.