Bug 869990 - [RHEV-H 6.4]cgconfig does not start with default configuration on RHEV-H.
[RHEV-H 6.4]cgconfig does not start with default configuration on RHEV-H.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Schiffer
Mike Gahagan
: Patch, Regression
Depends On:
Blocks: 870427 888457
  Show dependency treegraph
 
Reported: 2012-10-25 06:04 EDT by haiyang,dong
Modified: 2013-02-21 05:47 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: cgconfig service wasn't working properly with read-only file systems Consequence: cgconfig service wasn't able to start with default configuration on RHEV-H system Fix: added check for the read-only file systems to the cgconfig service Result: cgconfig service is working properly with default configuration on RHEV-H systems
Story Points: ---
Clone Of:
: 870427 (view as bug list)
Environment:
Last Closed: 2013-02-21 05:47:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-10-25 06:04:03 EDT
Description of problem:
/etc/init.d/cgconfig does not work well:
report "Starting cgconfig service: Error: cannot create directory /cgroup/cpuset" by execute service start/restart

[root@localhost admin]# /etc/init.d/cgconfig start
Starting cgconfig service: Error: cannot create directory /cgroup/cpuset
Loading configuration file /etc/cgconfig.conf failed
Cgroup, operation not allowed
Failed to parse /etc/cgconfig.conf                         [FAILED]
[root@localhost admin]# /etc/init.d/cgconfig restart
Stopping cgconfig service:                                 [  OK  ]
Starting cgconfig service: Error: cannot create directory /cgroup/cpuset
Loading configuration file /etc/cgconfig.conf failed
Cgroup, operation not allowed
Failed to parse /etc/cgconfig.conf                         [FAILED]

[root@localhost admin]# chkconfig |grep cgconfig
cgconfig               0:off        1:off        2:on        3:on        4:on        5:on        6:off

so default this cgconfig service was on, but /etc/init.d/cgconfig does not work well

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible:
100%

  
Steps to Reproduce:

Actual result:

Expect result:

Additional info:
No this issue in rhev-hypervisor6-6.3-20121023.0.el6_3, so it's a regression bug 
from 6.3 into 6.4
Comment 3 Mike Burns 2012-10-25 09:41:59 EDT
Sounds like we need a new entry in rwtab, and possibly need to pre-create the directory.
Comment 5 RHEL Product and Program Management 2012-10-25 20:40:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 6 Mike Gahagan 2012-11-20 08:51:13 EST
So just to get things straight, This looks like an artifact of / being mounted read-only in RHEV-H rather than a bug in libcgroup. I'm a bit confused because as as far as I know libcgroup has been using /cgroup since RHEL 6 was released so I don't think this is a regression. I suppose the default mount point could be changed to /sys/fs/cgroup but I don't know how disruptive that may be to existing configurations.
Comment 13 Mike Gahagan 2013-01-09 15:24:39 EST
I have confirmed that cgconfig will now work with a mount point specified on a read-only fs. I think we can mark this one verified, but I would like to hear from the RHEV-H folks that it is working in their environment first.
Comment 16 Mike Gahagan 2013-01-09 16:14:08 EST
The version tested in comment 13 was 0.37-7.el6.
Comment 18 errata-xmlrpc 2013-02-21 05:47:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0452.html

Note You need to log in before you can comment on or make changes to this bug.