Bug 870032 - devtoolset-1.1-binutils: wrong description of 'as -v' in man page
devtoolset-1.1-binutils: wrong description of 'as -v' in man page
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: binutils (Show other bugs)
DTS 1.1 RHEL 6
All Linux
low Severity low
: rc
: 1.1
Assigned To: Patsy Franklin
Martin Cermak
: Documentation, EasyFix
Depends On:
Blocks: 870125 1038339
  Show dependency treegraph
 
Reported: 2012-10-25 08:49 EDT by David Kaspar [Dee'Kej]
Modified: 2014-07-24 23:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: devtoolset-1.1-binutils-2.23.51.0.3-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 870125 1038339 (view as bug list)
Environment:
Last Closed: 2013-01-22 09:39:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaspar [Dee'Kej] 2012-10-25 08:49:15 EDT
Description of problem:
Manual page of GNU portable assembler 'as' has wrong description of -v option.
'-v' states for --verbose option, but in its man page it says, that '-v' option is used for showing version of this application.


Version-Release number of selected component (if applicable):
GNU assembler version 2.23.51.0.3-2.el6 20120918

How reproducible:
Always.


Steps to Reproduce:
1. Run 'as -v' and see its output.
2. Run 'as --verbose' and see its output.
Note: the outputs will be same and the program will be waiting for input from stdin.
3. Now run 'man as' and see the section describing '-v' option and what it says:
   "-v
    -version
         Print the as version."
  
Actual results:
Prints the version of the program. However, 'as' is then using --verbose mode and waiting for the input.

Expected results:
2 possible expected results:
-- 1) Man page is corrected and version displaying is provided only by '-version' and '--version' options.

-- 2) The as utility is patched to behave as described in its manual page. This would mean printing version information and exiting afterwards.


Additional info:
This issue has been found only on x86_64 RHEL-6.3 so far. However, it's possible that same issue is occuring on every other platform supported by DTS-1.1.
Comment 2 David Kaspar [Dee'Kej] 2012-10-25 11:08:51 EDT
I can now confirm, that this bug is also present on i386 and ppc64 architectures of DTS1.1 for RHEL6.
Comment 3 Marek Polacek 2012-10-25 14:05:46 EDT
I believe only the manpage should be fixed: s/-version/-verbose/.
Comment 5 Marek Polacek 2012-10-26 09:58:47 EDT
I don't think this is sufficient, even this line should be adjusted:
[@b{-v}] [@b{-version}] [@b{--version}] [@b{-W}] [@b{--warn}]
and there are more occurrences of "[^-]-version".
Comment 6 Marek Polacek 2012-10-29 06:42:17 EDT
Duh.  On the second though, we just have to correct manpage in sense that `-version' also exits.
Comment 7 Marek Polacek 2012-10-29 07:23:44 EDT
Patch posted upstream.
http://sourceware.org/ml/binutils/2012-10/msg00466.html
Comment 8 Marek Polacek 2012-10-30 10:08:25 EDT
Fixed.
Comment 12 errata-xmlrpc 2013-01-22 09:39:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0173.html

Note You need to log in before you can comment on or make changes to this bug.