Bug 870201 - Request to update to Publican 3
Request to update to Publican 3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Mach
Release Test Team
:
Depends On:
Blocks: 881866
  Show dependency treegraph
 
Reported: 2012-10-25 15:25 EDT by Stephen Gordon
Modified: 2012-12-19 10:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 04:17:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-10-25 15:25:50 EDT
Description of problem:

This is a request to add publican 3, as used for internal Red Hat content development, to RHEL 7. Publican is a tool for generating documentation output in a number of formats from a single HTML source. Publican is used to generate Red Hat's online documentation, Fedora's online documentation, and documentation for several packages that appear in RHEL itself.

Distribution of this major release of publican with RHEL 7 would assist layered products wishing to deploy documentation to customer sites with a consistent look and feel to that of the online documentation.
Comment 1 Bill Nottingham 2012-10-26 00:16:05 EDT
Looking at this, it would require at least 25 additional perl modules above and beyond what's currently in RHEL 7.

Is this something we might be able to ship in some sort of common tools for LP repo, rather than maintaining the perl infrastructure for the full RHEL lifecycle?
Comment 2 Stephen Gordon 2012-10-26 09:35:38 EDT
Possibly, my only question is how that meshes with having publican 2.8 in base-RHEL (mind you 2.8 which is what appears to be built for el7 right now is still a significant and much appreciated step up from what was in RHEL 6 which from memory was publican 2.1).
Comment 3 Bill Nottingham 2012-10-26 10:29:18 EDT
Hm, some of those may already be built there for RHEL 7 - I am going off the compsoed tree, which as of last week didn't have those modules (nor publican-2.8 itself). 

I suspect this is because none of the in-RHEL docs packages that require publican to build have been done for RHEL 7 yet.
Comment 4 Stephen Gordon 2012-10-26 10:40:17 EDT
(In reply to comment #3)
> Hm, some of those may already be built there for RHEL 7 - I am going off the
> compsoed tree, which as of last week didn't have those modules (nor
> publican-2.8 itself). 

Right, I was just looking/guessing from brew where I can see publican-2.8-4.1.el7 tagged into rhel-7.0.

> I suspect this is because none of the in-RHEL docs packages that require
> publican to build have been done for RHEL 7 yet.

The one example I did find that is already being built (or at least, attempting to be built ;)) was the Systemtap docs (see Bug # 849985).
Comment 5 Petr Pisar 2012-11-07 10:25:06 EST
I cannot grasp idea why to keep publican 2 in RHEL-7 while having publican 3 in separate repository.

Perl maintenance herd recognized public 2 as the only reverse dependency of another 31 perl packages which could go away from RHEL-7 if we moved publican 2 into separate repository.
Comment 6 Stephen Gordon 2012-11-07 11:23:56 EST
(In reply to comment #5)
> I cannot grasp idea why to keep publican 2 in RHEL-7 while having publican 3
> in separate repository.

Ideally I would actually prefer to just have one version, Publican 3, in RHEL-7 without having to use a separate repository/channel at all.

> Perl maintenance herd recognized public 2 as the only reverse dependency of
> another 31 perl packages which could go away from RHEL-7 if we moved
> publican 2 into separate repository.

I don't see how removing publican from RHEL-7 completely is a viable solution given it is used/required by other packages (systemtap docs, release notes, etc.). The decision required is more around which version to carry and who maintains it.
Comment 7 Bill Nottingham 2012-11-07 11:35:07 EST
Yeah, I was assuming it was request-to-replace, not request-to-add.
Comment 8 Jeff Fearn 2012-11-08 17:42:06 EST
I'm happy to be the maintainer of any publican deps the "Perl maintenance herd" don't want to cover.

There are a bunch of non-perl deps for P2 that could also go away by moving to P3, like FOP and a bunch of related Java packages.
Comment 9 Bill Nottingham 2012-11-08 17:45:06 EST
Wait, make both the perl and java teams' load lighter? I think we have a winner.

Do you have a test build releng can import? F18 still has 2.8.
Comment 12 Daniel Mach 2012-11-27 10:31:27 EST
Jeff,
could you specify exact package names and branches to be merged to rhel-7.0?
Comment 14 Daniel Mach 2012-11-28 04:17:47 EST
packages added
Comment 15 Petr Pisar 2012-12-19 10:09:12 EST
publican is not in comps definition file. Should it be?
Comment 16 Bill Nottingham 2012-12-19 10:48:38 EST
No, the intention is that it's there in the optional repo and the build root for our documentation to use.

Note You need to log in before you can comment on or make changes to this bug.