Bug 870218 - SELinux is preventing /usr/bin/python2.7 from using the 'sys_nice' capabilities.
SELinux is preventing /usr/bin/python2.7 from using the 'sys_nice' capabilities.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c5d92cc2ca507007b791877bd0f...
:
: 870219 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 16:13 EDT by Cole Robinson
Modified: 2012-12-10 11:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 11:13:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-25 16:13 EDT, Cole Robinson
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-25 16:13 EDT, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2012-10-25 16:13:07 EDT
Description of problem:
Triggered by fail2ban service startup. No special fail2ban config.

Additional info:
libreport version: 2.0.16
kernel:         3.6.2-4.fc17.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from using the 'sys_nice' capabilities.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should have the sys_nice capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep fail2ban-server /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:fail2ban_t:s0
:Target Context                system_u:system_r:fail2ban_t:s0
:Target Objects                 [ capability ]
:Source                        fail2ban-server
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-13.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-43.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.2-4.fc17.x86_64 #1 SMP Wed Oct
:                              17 02:43:21 UTC 2012 x86_64 x86_64
:Alert Count                   6
:First Seen                    2012-10-25 15:40:04 EDT
:Last Seen                     2012-10-25 15:51:28 EDT
:Local ID                      b0d63de6-704c-4074-877c-9b796e612ad3
:
:Raw Audit Messages
:type=AVC msg=audit(1351194688.441:111): avc:  denied  { sys_nice } for  pid=2040 comm="fail2ban-server" capability=23  scontext=system_u:system_r:fail2ban_t:s0 tcontext=system_u:system_r:fail2ban_t:s0 tclass=capability
:
:
:type=AVC msg=audit(1351194688.441:111): avc:  denied  { setsched } for  pid=2040 comm="fail2ban-server" scontext=system_u:system_r:fail2ban_t:s0 tcontext=system_u:system_r:fail2ban_t:s0 tclass=process
:
:
:type=SYSCALL msg=audit(1351194688.441:111): arch=x86_64 syscall=sched_setscheduler success=yes exit=0 a0=7f8 a1=0 a2=7fffed6376c0 a3=1 items=0 ppid=2039 pid=2040 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=fail2ban-server exe=/usr/bin/python2.7 subj=system_u:system_r:fail2ban_t:s0 key=(null)
:
:Hash: fail2ban-server,fail2ban_t,fail2ban_t,capability,sys_nice
:
:audit2allow
:
:#============= fail2ban_t ==============
:allow fail2ban_t self:capability sys_nice;
:allow fail2ban_t self:process setsched;
:
:audit2allow -R
:
:#============= fail2ban_t ==============
:allow fail2ban_t self:capability sys_nice;
:allow fail2ban_t self:process setsched;
:
Comment 1 Cole Robinson 2012-10-25 16:13:10 EDT
Created attachment 633559 [details]
File: type
Comment 2 Cole Robinson 2012-10-25 16:13:12 EDT
Created attachment 633560 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-25 16:32:53 EDT
Fixed in selinux-policy-3.11.1-45.fc18.noarch
Comment 4 Daniel Walsh 2012-10-25 16:33:44 EDT
*** Bug 870219 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-10-26 11:40:05 EDT
selinux-policy-3.11.1-46.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-46.fc18
Comment 6 Fedora Update System 2012-10-26 15:29:41 EDT
Package selinux-policy-3.11.1-46.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-46.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16862/selinux-policy-3.11.1-46.fc18
then log in and leave karma (feedback).
Comment 7 Cole Robinson 2012-12-10 11:13:48 EST
This has been fixed for a while.

Note You need to log in before you can comment on or make changes to this bug.