Bug 870219 - SELinux is preventing /usr/bin/python2.7 from using the 'setsched' accesses on a process.
SELinux is preventing /usr/bin/python2.7 from using the 'setsched' accesses o...
Status: CLOSED DUPLICATE of bug 870218
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9ae387bdb29cb37865833c85cdc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 16:13 EDT by Cole Robinson
Modified: 2012-10-25 16:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 16:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-25 16:13 EDT, Cole Robinson
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-25 16:13 EDT, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2012-10-25 16:13:41 EDT
Description of problem:
Triggered by fail2ban service startup. No special fail2ban config

Additional info:
libreport version: 2.0.16
kernel:         3.6.2-4.fc17.x86_64

description:
:SELinux is preventing /usr/bin/python2.7 from using the 'setsched' accesses on a process.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed setsched access on processes labeled fail2ban_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep fail2ban-server /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:fail2ban_t:s0
:Target Context                system_u:system_r:fail2ban_t:s0
:Target Objects                 [ process ]
:Source                        fail2ban-server
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-13.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-43.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.3-3.fc18.x86_64 #1 SMP Tue Oct
:                              23 14:55:06 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-25 15:46:11 EDT
:Last Seen                     2012-10-25 15:46:11 EDT
:Local ID                      a8ecdc3d-383a-4bdd-9ea4-30ddbf948447
:
:Raw Audit Messages
:type=AVC msg=audit(1351194371.571:284): avc:  denied  { setsched } for  pid=4134 comm="fail2ban-server" scontext=system_u:system_r:fail2ban_t:s0 tcontext=system_u:system_r:fail2ban_t:s0 tclass=process
:
:
:type=SYSCALL msg=audit(1351194371.571:284): arch=x86_64 syscall=sched_setscheduler success=yes exit=0 a0=1026 a1=0 a2=7fff562fca10 a3=1 items=0 ppid=4133 pid=4134 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=fail2ban-server exe=/usr/bin/python2.7 subj=system_u:system_r:fail2ban_t:s0 key=(null)
:
:Hash: fail2ban-server,fail2ban_t,fail2ban_t,process,setsched
:
:audit2allow
:
:#============= fail2ban_t ==============
:allow fail2ban_t self:process setsched;
:
:audit2allow -R
:
:#============= fail2ban_t ==============
:allow fail2ban_t self:process setsched;
:
Comment 1 Cole Robinson 2012-10-25 16:13:45 EDT
Created attachment 633561 [details]
File: type
Comment 2 Cole Robinson 2012-10-25 16:13:47 EDT
Created attachment 633562 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-25 16:33:44 EDT

*** This bug has been marked as a duplicate of bug 870218 ***

Note You need to log in before you can comment on or make changes to this bug.