Bug 870680 - Less is no longer the default pager given no envvars
Less is no longer the default pager given no envvars
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
:
: 871170 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-27 17:21 EDT by Ben Boeckel
Modified: 2012-12-20 11:17 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:17:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2012-10-27 17:21:26 EDT
Description of problem:
I've recently upgraded my machines and now man is using 'more' my default. Seeing as man-db Requires: less, it should probably be the default pager anyways.

Version-Release number of selected component (if applicable):
man-db-2.6.3-1.fc19.x86_64
Comment 1 Volker Sobek 2012-10-29 07:56:01 EDT
Same here after a fresh install of F18 Beta TC6.
Comment 2 Volker Sobek 2012-10-29 09:47:14 EDT
man-db-2.6.3-1.fc18 has been unpushed from testing: https://admin.fedoraproject.org/updates/FEDORA-2012-16954/man-db-2.6.3-1.fc18
Comment 3 Matthew Miller 2012-10-29 12:42:18 EDT
Of note: old man page for man itself (looking at a Fedora 15 test system) says:

       -P pager, --pager=pager
              Specify  which  output  pager to use.  By default, man uses less
              -s.  This option overrides the $MANPAGER  environment  variable,
              [...]

but the new man page says:

       -P pager, --pager=pager
              Specify  which  output  pager to use.  By default, man uses more
              -s.  This option overrides the $MANPAGER  environment  variable,

Were we patching this before, or is this an upstream change? (If it *is* an upstream change, should we fix it by patching it back, or by setting MANPAGER by default?)
Comment 4 Peter Schiffer 2012-10-30 07:11:23 EDT
Thanks guys for report.

Matthew: This is not an upstream change, man man page is dynamically updated by the configure script.

This should be fixed now in rawhide:
man-db-2.6.3-2.fc19
http://koji.fedoraproject.org/koji/buildinfo?buildID=363283
Comment 5 Fedora Update System 2012-10-30 07:24:28 EDT
man-db-2.6.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-16954/man-db-2.6.3-2.fc18
Comment 6 Ben Boeckel 2012-10-30 11:06:04 EDT
The configure output says it's using less at least (will try to test F18 later today).
Comment 7 Peter Schiffer 2012-11-01 12:02:04 EDT
*** Bug 871170 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2012-11-01 14:30:34 EDT
Package man-db-2.6.3-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.6.3-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16954/man-db-2.6.3-2.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-11-06 04:59:51 EST
man-db-2.6.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/man-db-2.6.3-2.fc18
Comment 10 Fedora Update System 2012-12-20 11:17:17 EST
man-db-2.6.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.