Bug 870684 - Consider setting unique name for VG for LVM installations
Consider setting unique name for VG for LVM installations
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-27 18:32 EDT by Milan Broz
Modified: 2013-02-28 23:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 19:55:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2012-10-27 18:32:22 EDT
Description of problem:

In previous Fedora releases automatically created LVM Volume Group during installation were named according to hostname of machine.

This somehow simplifies situations when you plug in disk with another LVM installation of Fedora to one machine (so there is no name conflict, similar to two fs with the same label).

LVM internally uses UUID for everything but if there are references to VG names (fstab for example) it cannot automatically resolve conflict.

Version-Release number of selected component (if applicable):
F18 Beta TC6 (+updates-lvm image for bug #870207))

How reproducible:
Just install, VG will be always named "fedora".

Expected results:

If there no hostname, as in previous question then some randomization of VG (suffix, name according to dhcp...) perhaps can help.
Ditto for LVM over LUKS - default "encrypt system" option.

I did not find option to change VG name even in manual partitioning...
Comment 1 David Lehman 2012-10-30 12:27:22 EDT
Radek, how do I obtain the system's hostname from ksdata in f18?
Comment 2 Radek Vykydal 2012-10-31 04:08:30 EDT
ksdata.network.hostname
It is already used in newVG and newBRTFS.
Comment 3 Radek Vykydal 2012-10-31 04:14:17 EDT
Hostname was broken in TC6 depending on configuration and what you do in UI - basically it returns None if you bring network in pre-hub standalone spoke. This should be fixed in 19.22. I think this BZ is just a consequence, i.e. a dupe of bug 866516.
Comment 4 David Lehman 2012-11-08 19:55:35 EST
I did a kickstart install today and it used the hostname in the vg name.

Note You need to log in before you can comment on or make changes to this bug.