Bug 870819 - [ja_JP] Test case failure: Host Tab [LAYOUT] - "no network assigned" translation doesn't fit a single line
[ja_JP] Test case failure: Host Tab [LAYOUT] - "no network assigned" translat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Linux
high Severity high
: ---
: 3.2.0
Assigned To: Einav Cohen
Yuko Katabami
ux
: i18n, ZStream
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-10-28 18:41 EDT by Yuko Katabami
Modified: 2013-06-11 04:22 EDT (History)
9 users (show)

See Also:
Fixed In Version: sf1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 883893 (view as bug list)
Environment:
Last Closed: 2013-06-11 04:18:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot: Setup Networks Dialog - No Network - seems to be fixed (35.82 KB, image/png)
2012-12-04 16:54 EST, Einav Cohen
no flags Details
Fixed Setup Host Networks (71.28 KB, image/png)
2013-01-09 00:25 EST, Lijun Li
no flags Details

  None (edit)
Description Yuko Katabami 2012-10-28 18:41:28 EDT
Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
unspecified

Steps to Reproduce: 
None


  * Hosts Tab

  * Select a host from the list

  * Click Network Interfaces tab 

  * Click Setup Host Networks




Actual results: 
#FIXME
Japanese translation for "Interfaces" (インターフェース) and Assigned Logical Networks" (割り当て済み論理ネットワーク) on the top do not fit in single line.

Expected results:
 
Should fit in single line
Comment 1 Shahar Havivi 2012-10-29 09:02:19 EDT
The string that is not fit to be in one line is the translation of "no network assigned".
In order to fit the Japanese string we need make the dialog much bigger, which is out of proportion.
Can you find a shorter string for that? maybe "not assigned" or something similar?
Comment 2 Yuko Katabami 2012-10-29 09:44:10 EDT
I can change it to "not assigned" but wonder if it still makes sense to users?
How many characters do you have to reduce?
Comment 3 Shahar Havivi 2012-10-29 10:27:08 EDT
Simon,
Can you please answer comment #2.
Comment 4 Simon Grinberg 2012-10-29 11:58:59 EDT
Translation could be "No networks"
Comment 5 Yuko Katabami 2012-10-29 23:47:50 EDT
We can change it to "No networks".
Translation has been updated in Zanata.
It is "ネットワーク定義なし". Four characters shorter than previous translation.
Comment 6 Shahar Havivi 2012-11-04 06:49:02 EST
"ネットワーク定義なし" fits well in the current dialog
Comment 7 Einav Cohen 2012-11-04 10:35:47 EST
Cannot be in ON_QA yet, since translation needs to be pushed to RHEV-M first -> moving to ON_DEV.
Comment 8 Einav Cohen 2012-11-29 12:14:57 EST
Hi Yuko,

I don't recall if we have already discussed it or not: 
Can you please verify that the translation has been updated in Zanata in the rhevm-3.1 version (in addition to the master version)?
Comment 10 Einav Cohen 2012-12-04 16:54:52 EST
Created attachment 657766 [details]
screen shot: Setup Networks Dialog - No Network - seems to be fixed
Comment 12 Einav Cohen 2012-12-04 17:01:31 EST
Yuko, I have pulled the updated (shorter) Japanese translation from Zanata and pushed it into the code.

I took a screen-shot of the updated Setup Networks dialog in Japanese, and it seems that the problem has been solved, however I am not sure, since no screen-shot of the problem was provided when the bug was originally reported.

Can you please confirm that once the new Japanese string is applied, the problem is solved? (see attachment 657766 [details])
Comment 13 Yuko Katabami 2012-12-04 17:39:24 EST
Hi Einav,

I confirmed that it has been fixed in the screenshot provided.

Thank you very much.
Comment 14 Einav Cohen 2012-12-05 00:02:16 EST
Thanks Yuko.

Moving to MODIFIED.
Comment 16 Lijun Li 2012-12-26 06:53:13 EST
Verified. It's fixed on RHEVM3.2 sf1 build.
[root@dhcp-8-215 ~]# rpm -q rhevm
rhevm-3.2.0-1.el6ev.noarch
[root@dhcp-8-215 ~]# rpm -q rhevm-webadmin-portal
rhevm-webadmin-portal-3.2.0-1.el6ev.noarch
Please see the attached screenshot.

Thanks,
Robert
Comment 17 Lijun Li 2013-01-09 00:22:47 EST
Verified on the latest rhevm3.2 sf build, it's fixed.
[root@rhevm32 ~]# rpm -q rhevm rhevm-webadmin-portal
rhevm-3.2.0-4.el6ev.noarch
rhevm-webadmin-portal-3.2.0-4.el6ev.noarch

Please refer to the attached screen shot.

Thanks,
Robert
Comment 18 Lijun Li 2013-01-09 00:25:50 EST
Created attachment 675258 [details]
Fixed Setup Host Networks
Comment 19 Itamar Heim 2013-06-11 04:18:21 EDT
3.2 has been released
Comment 20 Itamar Heim 2013-06-11 04:22:52 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.