This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 871030 - [abrt] Zim-0.56-3.fc17: pageview.py:2055:set_tags:AssertionError: BUG: Tags should have a name
[abrt] Zim-0.56-3.fc17: pageview.py:2055:set_tags:AssertionError: BUG: Tags s...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:f7e9b71928b6258b6d78999feaf...
:
: 895493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 08:57 EDT by Rui Gouveia
Modified: 2016-01-04 00:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 22:15:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1072986 None None None 2012-10-29 22:35:32 EDT

  None (edit)
Description Rui Gouveia 2012-10-29 08:57:09 EDT
Description of problem:
Copy+paste with the mouse

Version-Release number of selected component:
Zim-0.56-3.fc17

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.16
cmdline:        /usr/bin/python /usr/bin/zim
kernel:         3.6.3-1.fc17.x86_64

backtrace:
:pageview.py:2055:set_tags:AssertionError: BUG: Tags should have a name
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 4212, in do_delete_range
:    tree = self.buffer.get_parsetree(bounds, raw=True)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 2082, in get_parsetree
:    set_tags(iter, filter(_is_zim_tag, iter.get_tags()))
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 2055, in set_tags
:    assert attrib['name'], 'BUG: Tags should have a name'
:AssertionError: BUG: Tags should have a name
:
:Local variables in innermost frame:
:builder: <TreeBuilder object at 0x1752f38>
:tags: [<gtk.TextTag object at 0x1a1faf0 (GtkTextTag at 0x1a814c0)>]
:i: 0
:open_tags: []
:self: <TextBuffer object at 0x19a02d0 (zim+gui+pageview+TextBuffer at 0x204b490)>
:iter: <GtkTextIter at 0x1a8acf0>
:raw: True
:tag: <gtk.TextTag object at 0x1a1faf0 (GtkTextTag at 0x1a814c0)>
:t: 'tag'
:attrib: {'name': u''}
:continue_attrib: {}
Comment 1 Robin Lee 2013-01-15 20:31:29 EST
*** Bug 895493 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2013-01-24 08:15:58 EST
Zim-0.59-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/Zim-0.59-1.fc17
Comment 3 Fedora Update System 2013-01-25 16:30:43 EST
Package Zim-0.59-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Zim-0.59-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1478/Zim-0.59-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-02-04 22:15:25 EST
Zim-0.59-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.