Bug 895493 - [abrt] Zim-0.58-1.fc17: pageview.py:2069:set_tags:AssertionError: BUG: Tags should have a name
[abrt] Zim-0.58-1.fc17: pageview.py:2069:set_tags:AssertionError: BUG: Tags s...
Status: CLOSED DUPLICATE of bug 871030
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:08750d28db06fa53d6af7602883...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 05:54 EST by Rui Gouveia
Modified: 2016-01-04 00:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-15 20:31:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: executable (12 bytes, text/plain)
2013-01-15 05:54 EST, Rui Gouveia
no flags Details
File: core_backtrace (346 bytes, text/plain)
2013-01-15 05:54 EST, Rui Gouveia
no flags Details
File: environ (1.56 KB, text/plain)
2013-01-15 05:54 EST, Rui Gouveia
no flags Details
File: smolt_data (2.96 KB, text/plain)
2013-01-15 05:54 EST, Rui Gouveia
no flags Details

  None (edit)
Description Rui Gouveia 2013-01-15 05:54:14 EST
Description of problem:
deleting a tag with backspace a caracter at a time.

Version-Release number of selected component:
Zim-0.58-1.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python /usr/bin/zim --ipc-server-main /tmp/zim-rgouveia/zim-server-socket 30
kernel:         3.6.11-1.fc17.x86_64

backtrace:
:pageview.py:2069:set_tags:AssertionError: BUG: Tags should have a name
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 4248, in do_delete_range
:    tree = self.buffer.get_parsetree(bounds, raw=True)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 2096, in get_parsetree
:    set_tags(iter, filter(_is_zim_tag, iter.get_tags()))
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 2069, in set_tags
:    assert attrib['name'], 'BUG: Tags should have a name'
:AssertionError: BUG: Tags should have a name
:
:Local variables in innermost frame:
:builder: <zim.formats.TreeBuilder object at 0x1fe4410>
:bullet: None
:tags: [<gtk.TextTag object at 0x27f94b0 (GtkTextTag at 0x223c240)>, <gtk.TextTag object at 0x27f9370 (GtkTextTag at 0x2701200)>]
:i: 0
:open_tags: [(<gtk.TextTag object at 0x27f94b0 (GtkTextTag at 0x223c240)>, 'div')]
:self: <TextBuffer object at 0x2014370 (zim+gui+pageview+TextBuffer at 0x21faa10)>
:iter: <GtkTextIter at 0x269d850>
:raw: True
:tag: <gtk.TextTag object at 0x27f9370 (GtkTextTag at 0x2701200)>
:t: 'tag'
:attrib: {'name': u''}
:continue_attrib: {}
Comment 1 Rui Gouveia 2013-01-15 05:54:28 EST
Created attachment 678710 [details]
File: executable
Comment 2 Rui Gouveia 2013-01-15 05:54:31 EST
Created attachment 678711 [details]
File: core_backtrace
Comment 3 Rui Gouveia 2013-01-15 05:54:33 EST
Created attachment 678712 [details]
File: environ
Comment 4 Rui Gouveia 2013-01-15 05:54:35 EST
Created attachment 678713 [details]
File: smolt_data
Comment 5 Robin Lee 2013-01-15 20:31:29 EST

*** This bug has been marked as a duplicate of bug 871030 ***

Note You need to log in before you can comment on or make changes to this bug.