Bug 871132 - Protected wifi connection not enabled after secrets are set, user has to re-select it
Protected wifi connection not enabled after secrets are set, user has to re-s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-29 13:37 EDT by Adam Williamson
Modified: 2012-11-26 09:07 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.24-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:40:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-10-29 13:37:24 EDT
Splitting off from Reartes Guillermo's report in https://bugzilla.redhat.com/show_bug.cgi?id=855526#c26 :

It seems that when configuring a protected wifi connection in anaconda 18.19 (Beta TC6), you have to select the AP, enter the password, then select the AP again before it will connect. User probably expects it to connect immediately after entering the password.

This doesn't seem serious enough to merit blocker status, but possibly NTH. If not fixed, we should document it in CommonBugs.
Comment 1 satellitgo 2012-10-29 14:05:40 EDT
I just tested this and wlan0 does not connect with TC6 Netinstall 
tried reselecting wlan0 and also turning on/off/on
also continue and reselecting network  
hit done and got error anaconda exception report
 AttributeError 'NoneType' object has no attribute 'get'
cc'd BZ 868535
Comment 2 Adam Williamson 2012-10-31 15:41:46 EDT
Discussed at 2012-10-31 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-31/f18beta-blocker-review-6.2012-10-31-16.00.log.txt . Accepted as NTH, but we note this isn't really a showstopper of an issue, and you could possibly make things worse by poking it. So anaconda team, please review any fix for this carefully, and merge it only if you're really pretty confident about it. We don't want a 'eh, we think this might fix it, let's throw it at the wall and see if it sticks' fix.
Comment 3 Fedora Update System 2012-11-02 21:02:40 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 4 Fedora Update System 2012-11-03 15:27:13 EDT
Package anaconda-18.24-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.24-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17543/anaconda-18.24-1.fc18
then log in and leave karma (feedback).
Comment 5 Tom Lane 2012-11-04 11:45:29 EST
Works for me now in Beta-TC7.
Comment 6 Fedora Update System 2012-11-05 20:37:54 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 7 Fedora Update System 2012-11-06 21:09:52 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 8 Fedora Update System 2012-11-07 22:24:09 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 9 Adam Williamson 2012-11-08 04:40:12 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.