Bug 871354 - "sec" string (within refresh-rate drop-down items) is not localized
"sec" string (within refresh-rate drop-down items) is not localized
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Linux
high Severity medium
: ---
: 3.2.0
Assigned To: Alexander Wels
Lijun Li
ux
: CodeChange, Translation
Depends On:
Blocks: 908377 950215
  Show dependency treegraph
 
Reported: 2012-10-30 06:15 EDT by Lijun Li
Modified: 2015-09-22 09 EDT (History)
12 users (show)

See Also:
Fixed In Version: sf13.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 908377 950215 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized logs and string 'Refresh Rate, 5 sec ...' in Event Tab. (106.43 KB, image/png)
2012-10-30 06:17 EDT, Lijun Li
no flags Details
Screen-Shot: Refresh-button tool-tip (138.82 KB, image/png)
2013-01-15 15:53 EST, Einav Cohen
no flags Details
Screen-Shot: Refresh-button drop-down (141.09 KB, image/png)
2013-01-15 15:54 EST, Einav Cohen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 13525 None None None Never

  None (edit)
Description Lijun Li 2012-10-30 06:15:04 EDT
Description of problem:


Version-Release number of selected component (if applicable):
3.1.0-22.el6ev

How reproducible:
100%


Steps to Reproduce:
1. Log in RHEVM Admin Portal.
2. Click on the right Event tab
3. Click on the right refresh drop-down arrow button 
  
Actual results:
Unlocalized logs and string 'Refresh Rate, 5 sec ...' in Event Tab

Expected results:
Those strings should be localized.

Additional info:
Comment 1 Lijun Li 2012-10-30 06:17:14 EDT
Created attachment 635466 [details]
Unlocalized logs and string 'Refresh Rate, 5 sec ...' in Event Tab.
Comment 2 Oved Ourfali 2012-10-30 12:39:06 EDT
Commit: cb65b1bb137e51cffd8b8dbc87c3a549336a01dc
 
http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=cb65b1bb137e51cffd8b8dbc87c3a549336a01dc
Comment 4 A S Alam 2012-11-12 22:37:43 EST
Bug: Not fixed
Package: rhevm-3.1.0-28.el6ev.noarch
si24.1
Comment 5 Oved Ourfali 2012-11-13 01:14:41 EST
(In reply to comment #4)
> Bug: Not fixed
> Package: rhevm-3.1.0-28.el6ev.noarch
> si24.1

That's weird, is it is a very simple fix.
Is it possible that this new entry wasn't translated in the zanata files?
Who can tell us that?
I'll try to have a look at Zanata itself, and check if it was translated.
Comment 6 Lijun Li 2012-11-13 01:32:00 EST
(In reply to comment #5)
> (In reply to comment #4)
> > Bug: Not fixed
> > Package: rhevm-3.1.0-28.el6ev.noarch
> > si24.1
> 
> That's weird, is it is a very simple fix.
> Is it possible that this new entry wasn't translated in the zanata files?
> Who can tell us that?
> I'll try to have a look at Zanata itself, and check if it was translated.

Cc "Yuko Katabami" <ykatabam@redhat.com> from L10n team here to confirm this.

Thanks,
Robert
Comment 7 Yuko Katabami 2012-11-13 01:42:04 EST
I confirmed that the string is not included in Zanata files.
Comment 8 Yuko Katabami 2012-11-13 01:45:27 EST
Please also check this: #870294
https://bugzilla.redhat.com/show_bug.cgi?id=870294

Itamar states that "alerts/events/tasks are not part of localization scope of the version"
Comment 9 Einav Cohen 2012-11-13 09:34:10 EST
(In reply to comment #8)
> Please also check this: #870294
> https://bugzilla.redhat.com/show_bug.cgi?id=870294
> 
> Itamar states that "alerts/events/tasks are not part of localization scope
> of the version"

Correct.

The only issue in this bug is the Refresh Rate part -> changing subject accordingly.
Comment 11 Yuko Katabami 2012-11-13 16:32:58 EST
Found the string "Refresh Interval: {0} sec" in Zanata, however this seems to be only used for a popup (it shows in ja-JP) when mouse over "Refresh Rate" in the dropdown menu.
Comment 12 Einav Cohen 2013-01-15 15:53:30 EST
Created attachment 679061 [details]
Screen-Shot: Refresh-button tool-tip
Comment 13 Einav Cohen 2013-01-15 15:54:06 EST
Created attachment 679063 [details]
Screen-Shot: Refresh-button drop-down
Comment 14 Einav Cohen 2013-01-15 15:54:42 EST
[clearing needinfo on eng-l10n-bugs]
Comment 15 Einav Cohen 2013-01-15 16:40:16 EST
(In reply to comment #11)
> Found the string "Refresh Interval: {0} sec" in Zanata, however this seems
> to be only used for a popup (it shows in ja-JP) when mouse over "Refresh
> Rate" in the dropdown menu.

Indeed - the Refresh-button tool-tip is localized as seen in attachment 679061 [details].

Regarding the refresh-button drop-down (see attachment 679063 [details]):
The "Refresh Rate" text within the drop-down is localized appropriately (this is Oved's fix, I assume, from Comment #2, Comment #3).
However:
- The "Refresh Rate" text in Japanese is broken into two lines - need to extend the drop-down width a little bit in order to fix it.
- The "sec" text in the drop-down items (5 sec, 10 sec, etc.) is not localized.
Comment 18 Einav Cohen 2013-02-06 10:21:27 EST
(In reply to comment #15)
> Regarding the refresh-button drop-down (see attachment 679063 [details]):
> ...
> - The "Refresh Rate" text in Japanese is broken into two lines - need to
> extend the drop-down width a little bit in order to fix it.

update: Japanese translation will be shortened (tracked via bug 908377), so current drop-down width should be sufficient; 
no need to extend the drop-down width.

> - The "sec" text in the drop-down items (5 sec, 10 sec, etc.) is not
> localized.

this issue still needs to be addressed.
Comment 22 Itamar Heim 2013-06-11 04:48:40 EDT
3.2 has been released
Comment 23 Itamar Heim 2013-06-11 04:48:42 EDT
3.2 has been released
Comment 24 Itamar Heim 2013-06-11 04:48:43 EDT
3.2 has been released
Comment 25 Itamar Heim 2013-06-11 04:53:41 EDT
3.2 has been released
Comment 26 Itamar Heim 2013-06-11 05:24:20 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.