This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 871370 - [zh_CN]Redundant name string '空白' in the blank column header and Unlocalized column name 'Correlation Id' in Event sub tab [LAYOUT]
[zh_CN]Redundant name string '空白' in the blank column header and Unlocalized ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Linux
high Severity medium
: ---
: 3.2.0
Assigned To: Manuel Ospina
Lijun Li
ux
: i18n, Reopened, Translation, ZStream
Depends On:
Blocks: 894504 915537
  Show dependency treegraph
 
Reported: 2012-10-30 06:45 EDT by Lijun Li
Modified: 2015-11-09 19:10 EST (History)
13 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 894504 (view as bug list)
Environment:
Last Closed: 2012-10-31 03:49:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Truncation and Unlocalized column name in Event sub tab (74.09 KB, image/png)
2012-10-30 06:46 EDT, Lijun Li
no flags Details
Event tab in ja-JP (245.94 KB, image/png)
2012-10-31 02:21 EDT, Yuko Katabami
no flags Details
CorrelationID zh-CN in Zanata "rhevm-3.1" version (64.43 KB, image/png)
2012-11-07 10:33 EST, Einav Cohen
no flags Details
Fixed Event sub tab (85.67 KB, image/png)
2013-01-31 04:20 EST, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-10-30 06:45:26 EDT
Description of problem:
Truncation and Unlocalized column name in Event sub tab

Version-Release number of selected component (if applicable):
3.1.0-22.el6ev

How reproducible:
100%


Steps to Reproduce:
1. Log in RHEVM Admin Portal.
2. Click on the right DataCenter tab.
3. Select one entry, under the details sub tabs, click on the right Event sub tab. 
  
Actual results:
blank column name trancated and and unlocalized column name 'Correlation Id'

Expected results:


Additional info:
zh_CN locale
Comment 1 Lijun Li 2012-10-30 06:46:44 EDT
Created attachment 635490 [details]
Truncation and Unlocalized column name in Event sub tab
Comment 6 Yuko Katabami 2012-10-31 02:20:45 EDT
Checked on the test sytem for ja-JP. 

'Correlation Id' is localized, but "blank column header" is empty.
(please see attached image)
Is it supposed to be translated in the first place?
It seems to me only a status column.
Comment 7 Yuko Katabami 2012-10-31 02:21:45 EDT
Created attachment 635948 [details]
Event tab in ja-JP
Comment 8 Lijun Li 2012-10-31 02:39:08 EDT
cc'ed "Leah Liu" <lliu@redhat.com> zh_CN translator from L10n team for tracking this.
Comment 9 Wei Liu 2012-10-31 03:16:35 EDT
String "Correlation Id" is translated on Zanata.
Comment 10 Oved Ourfali 2012-10-31 03:49:41 EDT
(In reply to comment #6)
> Checked on the test sytem for ja-JP. 
> 
> 'Correlation Id' is localized, but "blank column header" is empty.
> (please see attached image)
> Is it supposed to be translated in the first place?
> It seems to me only a status column.

This one is empty in all languages.
Closing this bug, as looks like all issues are solved now (no need for title, and correlation id is translated properly).
Comment 11 Lijun Li 2012-10-31 04:22:31 EDT
(In reply to comment #10)
> (In reply to comment #6)
> > Checked on the test sytem for ja-JP. 
> > 
> > 'Correlation Id' is localized, but "blank column header" is empty.
> > (please see attached image)
> > Is it supposed to be translated in the first place?
> > It seems to me only a status column.
> 
> This one is empty in all languages.
> Closing this bug, as looks like all issues are solved now (no need for
> title, and correlation id is translated properly).

Hi Oved,
I don't think you can closed this as NOTABUG by now, 

1. As We need to verify and confirm if the translated string from Zanata is built to the later build.

2. for zh_CN, if the first column name is empty, please remove the title for it (‘空白’) and should not be truncated.

re-open the bug.

Thanks,
Robert
Comment 14 Wei Liu 2012-11-01 00:32:53 EDT
Hi Robert,

“空白” has been removed for the empty string on Zanata.

cheers
Leah
Comment 15 Einav Cohen 2012-11-02 10:37:44 EDT
According to Comment #9 and Comment #14, I assume that this bug is actually solved: strings were updated in Zanata, all left to do is pull strings from Zanata and push them into rhev-m code repo -> giving a devel_ack based on that.
Comment 16 Einav Cohen 2012-11-06 09:01:19 EST
since strings are updated within Zanata, marking as ON-DEV (all left to do is pull strings from Zanata and push to rhevm).
Comment 17 Einav Cohen 2012-11-07 10:33:16 EST
Created attachment 640162 [details]
CorrelationID zh-CN in Zanata "rhevm-3.1" version
Comment 18 Einav Cohen 2012-11-07 10:36:04 EST
It seems that after the manual "copy translation" from "master" to "rhevm-3.1" version in Zanata, the fixes from comment #9 and comment #14 were overriden (see attachment 640162 [details]).

So need to wait for the translators to go over the problematic translations and update them. Only then we will be able to pull the updated translations from Zanata and push into the code.
Comment 19 Einav Cohen 2012-11-07 10:38:16 EST
Yuko - please pay attention to Comment #18. thanks.
Comment 21 Yuko Katabami 2012-11-07 18:26:30 EST
Hi Einav,

ja-JP had the same problem - the latest translation was overriden by previous translation during manual copytrans and I had to fix manually. I expected this to happen in simplified Chinese as last minute changes were made.
I will be advising simplified Chinese translater to fix this in rhevm-3.1 version. Would you like me to get this done today or when we make all the updates in translation?
Comment 22 Yuko Katabami 2012-11-07 19:01:45 EST
Hi Einav,

Leah (Wei Liu) checked strings with "空白" in rhevm-3.1 version, but she could not find any of them.
She found "Correlation ID" untranslated, so she translated it.
Please let me know if you need any other help.
Comment 23 Einav Cohen 2012-11-08 11:29:45 EST
Hi Yuko,

(In reply to comment #21)
>  Would you like me to get this done today or when we make all the
> updates in translation?

Doesn't matter - whatever is more comfortable for you; you can wait until I push the most updated translations.

(In reply to comment #22)
> Leah (Wei Liu) checked strings with "空白" in rhevm-3.1 version, but she could
> not find any of them.
> She found "Correlation ID" untranslated, so she translated it.
> Please let me know if you need any other help.

Thanks Yuko.
I am not sure if the strings in this BZ were the only problem; I guess that pretty much all the work that was done on the "rhevm-3.1" version and was not done in the "master" version was overridden as part of the manual copy-translations process.
However I believe that Sean/Manuel were able to help you, providing the relevant "diffs" for you to examine?
Comment 24 Yuko Katabami 2012-11-08 18:37:23 EST
Thanks Einav.
We (all langs) will do the rest of updates including the ones listed in diffs when you push extra strings to zanata.
Comment 25 Einav Cohen 2012-12-04 17:39:46 EST
translators: need to do the following on the "master" version of the "oVirt" project in Zanata:

- Make sure that empty string is indeed empty (it should be, but need to make sure - see comments #14, #18, #22, ...)

- Make sure that "Correlation ID" is translated.
Comment 26 Einav Cohen 2013-01-10 00:38:31 EST
localization team confirmed that translations in "master" version of "oVirt" Zanata project are completed.
Comment 27 Einav Cohen 2013-01-10 00:56:02 EST
patch sent upstream with latest updated translations pulled from "master" version of "oVirt" project in Zanata:

http://gerrit.ovirt.org/#/c/10842/
Comment 30 Lijun Li 2013-01-31 04:20:15 EST
Verified it's fixed on the sf4 build:
# rpm -q rhevm rhevm-webadmin-portal
rhevm-3.2.0-5.el6ev.noarch
rhevm-webadmin-portal-3.2.0-5.el6ev.noarch

Please refer to the attached screenshot.
Comment 31 Lijun Li 2013-01-31 04:20:48 EST
Created attachment 690796 [details]
Fixed Event sub tab
Comment 32 Itamar Heim 2013-06-11 05:03:40 EDT
3.2 has been released
Comment 33 Itamar Heim 2013-06-11 05:03:44 EDT
3.2 has been released
Comment 34 Itamar Heim 2013-06-11 05:03:49 EDT
3.2 has been released
Comment 35 Itamar Heim 2013-06-11 05:04:19 EDT
3.2 has been released
Comment 36 Itamar Heim 2013-06-11 05:33:27 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.