Bug 871420 - [RFE][Tracker][TestOnly] - WebAdmin should display correctly on low resolutions.
Summary: [RFE][Tracker][TestOnly] - WebAdmin should display correctly on low resolutions.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.2.0
: ---
Assignee: Tomas Jelinek
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
: 1026267 (view as bug list)
Depends On: 879319 879324 879329 879334 1148392 1511906 1511908 1511914
Blocks: 906806
TreeView+ depends on / blocked
 
Reported: 2012-10-30 12:21 UTC by Toni Willberg
Modified: 2019-05-16 13:03 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 17:35:57 UTC
oVirt Team: UX
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)
screenshot: new server dialog window (141.76 KB, image/png)
2012-10-30 12:21 UTC, Toni Willberg
no flags Details
screenshot: configure dialog window (138.96 KB, image/png)
2012-10-30 12:22 UTC, Toni Willberg
no flags Details
New/Edit Pool dialog screen-shot (36.94 KB, image/png)
2012-11-07 21:19 UTC, Einav Cohen
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 755550 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Bugzilla 818051 0 unspecified CLOSED PRD34 - [RFE] Webadmin's layout is broken when not enough display real-estate [main-tab clutter, sub-tab clutter, button... 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:37:49 UTC

Internal Links: 755550 818051

Description Toni Willberg 2012-10-30 12:21:29 UTC
Created attachment 635542 [details]
screenshot: new server dialog window

Description of problem:
 rhevm-webadmin-portal-3.1.0-18.el6ev.noarch

 Many webadmin dialog windows are too large for 13" screen. See attachments for examples.

 Tested on Lenovo Thinkpad X220, running RHEL 6 workstation.
 firefox-10.0.10-1.el6_3.x86_64

 The screen can be scrolled, but the dialog windows seem to have lots of empty space; would be better to shrink the dialog windows first and only then require user to scroll the browser.

Comment 1 Toni Willberg 2012-10-30 12:22:30 UTC
Created attachment 635547 [details]
screenshot: configure dialog window

Comment 2 Toni Willberg 2012-10-30 12:23:48 UTC
Thinkpad X220 has native screen resolution of 1366x768.

Comment 3 Yaniv Kaul 2012-10-30 12:44:54 UTC
X220 is actually 12.5". Rephrased title - the problem is not the screen size but the resolution.

Comment 4 Einav Cohen 2012-11-07 21:19:20 UTC
Created attachment 640393 [details]
New/Edit Pool dialog screen-shot

Comment 5 Einav Cohen 2012-11-07 21:25:23 UTC
(In reply to comment #0)
>  The screen can be scrolled, but the dialog windows seem to have lots of
> empty space; would be better to shrink the dialog windows first and only
> then require user to scroll the browser.

This dialog is the base-line for all New/Edit VM-like business entities (Templates, Pools).
The New/Edit Pool dialog, for example, contains more details in its "General" section, therefore we cannot shrink it drastically; for clarification, see attachment 640393 [details]

So there would probably be no escape from supporting a scrollable content for the dialog(s) (at least vertically).

Comment 8 Einav Cohen 2013-12-02 13:34:59 UTC
*** Bug 1026267 has been marked as a duplicate of this bug. ***

Comment 9 Einav Cohen 2014-01-16 14:29:05 UTC
Arthur: Per Itamar's recommendation: We need to close this BZ and open a BZ on each "painful" dialog (and assign each one of them to the relevant group). 

Can you please list the "painful" dialogs that need to be treated?

I would say that some dialogs around 'virt' (New/Edit VM/Template/Pool, Run Once) would need to be treated here, might worth to take a look at New Storage Domain, New Host, New Cluster, Configure. Thanks.

Comment 10 Arthur Berezin 2014-01-22 08:10:03 UTC
I think we need to test this for all dialogs with 1366x768 resolution and produce a list of all "too big" dialogs, Pavel can QE help out?

In general I think we would prefer to have more tabs instead of making scrollable dialogs, but we would have to go over the list to see where that would make sense.

Comment 11 Pavel Stehlik 2014-01-22 12:07:52 UTC
Although looks like nice job for automation - the manual approach would be faster here. What would be the best - to have list of these dialogs(with their default resolution). I already spoke with Vojtech & he' be able to deliver it (e.g. as att of this BZ).
Thank you, P.

Comment 12 Vojtech Szocs 2014-01-22 14:00:36 UTC
As discussed with Pavel, I'll provide the list of dialogs and their default (initial) sizes soon.

Please note that sometimes the same dialog type is used in different contexts, so the list might be shorter.

Leaving needinfo set on me.

Comment 13 Arthur Berezin 2014-02-12 16:53:48 UTC
Due to capacity moving to 3.5.

Comment 19 Lucie Leistnerova 2017-11-10 10:55:16 UTC
New UI does not display on low resolution correctly. See depending BZ.

Comment 20 Greg Sheremeta 2017-11-30 15:00:15 UTC
moving back to 4.2, as all should be good now

Comment 21 Greg Sheremeta 2017-12-06 13:22:54 UTC
Lucie, can we keep this one separate from the mobile one? That way we can test low res screens in the browser for 4.2, and mobile will be pushed to 4.3.

Comment 22 Lucie Leistnerova 2017-12-06 13:31:02 UTC
Alright, no problem.

Comment 24 Lucie Leistnerova 2017-12-11 11:50:35 UTC
Dialogs in new UI look good now.

Comment 27 errata-xmlrpc 2018-05-15 17:35:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 28 Franta Kust 2019-05-16 13:03:19 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.