Bug 871822 - RAM value listed should be "memory.memtotal" fact
RAM value listed should be "memory.memtotal" fact
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jordan OMara
Tazim Kolhar
: Triaged
: 871911 (view as bug list)
Depends On:
Blocks: sam13-tracker 873443
  Show dependency treegraph
 
Reported: 2012-10-31 09:24 EDT by Tom McKay
Modified: 2016-04-25 20:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 873443 (view as bug list)
Environment:
Last Closed: 2013-10-01 06:52:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mem_total value is set (57.79 KB, image/png)
2013-08-12 08:16 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tom McKay 2012-10-31 09:24:01 EDT
Instead of "dmi.memory.size" the fact "memory.memtotal" should be displayed since that is what candlepin uses for subscriptions. (The dmi fact also won't be available on all arch such as s390, ppc, and ia64.)

Display to the user should be converted to MB rather than the full integer.
Comment 2 Michael Stead 2012-10-31 09:37:05 EDT
subscription-manager actually converts the 'memory.memtotal' value to GB before comparing it to the subscription's 'ram' attribute value (which is specified in GB). Candlepin will have to do the same.

Perhaps katello could display the same calculated value?

This is how subscription-manager does the conversion (python):
ram_gb = int(round(memory_memtotal / 1024.0 / 1024.0))
Comment 3 Jordan OMara 2012-10-31 15:57:31 EDT
*** Bug 871911 has been marked as a duplicate of this bug. ***
Comment 4 Jordan OMara 2012-11-05 16:18:21 EST
https://github.com/Katello/katello/pull/970
Comment 5 Bryan Kearney 2013-06-07 14:19:30 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 6 Tazim Kolhar 2013-08-12 08:16:44 EDT
Created attachment 785667 [details]
Mem_total value is set

VERIFIED :

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch
Comment 8 errata-xmlrpc 2013-10-01 06:52:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.