Bug 871911 - Can't register system via api when fact dmi.memory.size isn't present
Can't register system via api when fact dmi.memory.size isn't present
Status: CLOSED DUPLICATE of bug 871822
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Jordan OMara
Katello QA List
: Triaged
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-10-31 13:21 EDT by Jeff Weiss
Modified: 2014-11-09 17:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-31 15:57:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2012-10-31 13:21:00 EDT
Description of problem:


Version-Release number of selected component (if applicable):
{:name "Headpin", :version "1.2.1-1.git.234.00b4cb9.el6"}
but also affects Katello

How reproducible:
always

Steps to Reproduce:
1. create system via api, eg POST https://10.16.120.193/headpin//api/environments/20/consumers 

with some facts not including the key "dmi.memory.size"
2.
3.
  
Actual results:
[ERROR: 2012-10-31 10:20:48 #7754] NoMethodError: private method `split' called for nil:NilClass
/usr/share/katello/app/models/glue/candlepin/consumer.rb:323:in `memory_in_megabytes'
/usr/share/katello/app/models/glue/candlepin/consumer.rb:290:in `memory'
/usr/share/katello/app/models/indexed_model.rb:148:in `send'
/usr/share/katello/app/models/indexed_model.rb:148:in `to_indexed_json'
/usr/share/katello/app/models/indexed_model.rb:147:in `each'
/usr/share/katello/app/models/indexed_model.rb:147:in `to_indexed_json'

Expected results:
system created.

Additional info:
Comment 2 Jordan OMara 2012-10-31 15:57:31 EDT

*** This bug has been marked as a duplicate of bug 871822 ***

Note You need to log in before you can comment on or make changes to this bug.