Bug 871940 - grub2-install does not work on multipath
grub2-install does not work on multipath
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
18
ppc64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On: 874234
Blocks: F18Blockerppc
  Show dependency treegraph
 
Reported: 2012-10-31 14:59 EDT by Mark Hamzy
Modified: 2015-05-12 16:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 11:28:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Hamzy 2012-10-31 14:59:26 EDT
14:31:21,468 INFO program: Running... grub2-install --no-nvram --no-floppy /dev/mapper/mpatha1
14:31:22,459 ERR program: /usr/sbin/grub2-probe: warning: unknown device type dm-3
14:31:22,459 ERR program: .
14:31:22,497 ERR program: The chosen partition is not a PReP partition.

             Device Boot      Start         End      Blocks   Id  System
/dev/mapper/mpatha1   *        2048       10239        4096   41  PPC PReP Boot
/dev/mapper/mpatha2           10240     1034239      512000   83  Linux
/dev/mapper/mpatha3         1034240     7129087     3047424   82  Linux swap / Solaris
/dev/mapper/mpatha4         7129088    31457279    12164096    5  Extended
/dev/mapper/mpatha5         7131136    31457279    12163072   83  Linux

[anaconda root@riley6 ~]# chroot /mnt/sysimage/
[anaconda root@riley6 /]# grub2-install --no-nvram --no-floppy /dev/mapper/mpatha1
/usr/sbin/grub2-probe: warning: unknown device type dm-3
.
The chosen partition is not a PReP partition.
[anaconda root@riley6 /]# grub2-probe /dev/mapper/mpatha1
grub2-probe: error: failed to get canonical path of devtmpfs.
[anaconda root@riley6 /]# grub2-probe -d /dev/dm-3
ext2
Comment 2 Mark Hamzy 2012-10-31 15:04:12 EDT
I should also mention that anaconda is now running kpartx without the "-p p" option.
Comment 3 Gustavo Luiz Duarte 2012-11-22 10:33:16 EST
This is caused by malformed device UUIDs.

Grub2 relies on dm UUID to identify a multipath device and also to differentiate a multipath device from its partitions.

You can get the UUID of the partition by running the following command:
dmsetup info /dev/mapper/mpatha1

The first partition on a multipath device should have a UUID like:
part1-mpath-blablabla

However, for some reason, when anaconda creates the partitions on a multipath disk, the partitions get assigned a UUID like:
mpath-blablablap1
Note the 'p1' at the end of the UUID.

Grub2 should work fine if the multipath devices get assigned proper UUID's.
Comment 4 Karsten Hopp 2012-11-28 13:02:43 EST
moving to F18Blockerppc
Comment 5 Phil Knirsch 2012-12-04 11:28:23 EST
As Gustavo mentioned, this seems to have been a leftover uuid issue and not a multipath problem in itself.

Closing this bug then as NOTABUG.

Thanks & regards, Phil

Note You need to log in before you can comment on or make changes to this bug.