Bug 874234 - GRUB2 fails to install if destination is a symlink (powerpc-ieee1275)
GRUB2 fails to install if destination is a symlink (powerpc-ieee1275)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
18
powerpc Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 871940
  Show dependency treegraph
 
Reported: 2012-11-07 13:38 EST by Paulo Flabiano Smorigo
Modified: 2012-12-06 02:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 02:25:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adds the parameter to fix the problem (1.25 KB, patch)
2012-11-07 13:40 EST, Paulo Flabiano Smorigo
no flags Details | Diff

  None (edit)
Description Paulo Flabiano Smorigo 2012-11-07 13:38:30 EST
Description of problem:
If the device used in grub2-install is a symlink, the file command must "follow
the link" in order to check the real device.


How reproducible:
# grub2-install /dev/mapper/mpatha1
The PReP partition is not empty. If you are sure you want to use it, run dd to clear it:
  dd if=/dev/zero of=/dev/mapper/mpatha1

This is because the destination is a symlink:
lrwxrwxrwx.  1 root root       7 Nov  7 15:59 mpatha1 -> ../dm-1
Comment 1 Paulo Flabiano Smorigo 2012-11-07 13:40:51 EST
Created attachment 640268 [details]
Adds the parameter to fix the problem
Comment 2 Fedora Update System 2012-11-27 15:36:00 EST
grub2-2.00-13.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/grub2-2.00-13.fc18
Comment 3 Fedora Update System 2012-11-27 21:12:00 EST
Package grub2-2.00-13.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grub2-2.00-13.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19181/grub2-2.00-13.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-12-06 02:25:30 EST
grub2-2.00-13.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.