This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 871987 - Split-brain logging is confusing
Split-brain logging is confusing
Status: CLOSED DUPLICATE of bug 864963
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
All All
medium Severity low
: ---
: ---
Assigned To: vsomyaju
:
Depends On:
Blocks: 878881
  Show dependency treegraph
 
Reported: 2012-10-31 18:36 EDT by Dynamic Packet
Modified: 2015-03-04 19:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 878881 (view as bug list)
Environment:
Last Closed: 2013-02-22 04:48:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dynamic Packet 2012-10-31 18:36:41 EDT
Description of problem:

 Currently, split-brain logs are not cleared after resolution. This may (and does) confuse users who manually heal/fix split-brain'ed files but still see them in this log. Its equally confusing that if you miss files in this process and heal again, the split-brain list grows. 

How reproducible:

 Every time

Steps to Reproduce:
1. Create volume with replica 2
2. Cause split-brain on 1 file
3. Manually fix split-brain
4. Log entry still appears
  
Expected results:

 It would be great if the split-brain list was cleared when starting another heal. Or if the files could be removed from the list once the split-brain state was fixed manually.
Comment 1 Pranith Kumar K 2012-11-02 03:25:39 EDT
hi,
  Could you explain what you mean by log. The one that is written to the file or the entry that appears in 'volume heal <volname> info split-brain'? Could you also let us know the version of gluster you are using.

Pranith
Comment 2 Joe Julian 2012-11-02 10:11:35 EDT
This is referring to the 'volume heal <volname> info split-brain' output on any of the release-3.3 versions.
Comment 3 Pranith Kumar K 2013-02-22 04:48:26 EST

*** This bug has been marked as a duplicate of bug 864963 ***

Note You need to log in before you can comment on or make changes to this bug.