Bug 864963 - Heal-failed and Split-brain messages are not cleared after resolution of issue
Heal-failed and Split-brain messages are not cleared after resolution of issue
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: vsomyaju
:
: 871987 905203 (view as bug list)
Depends On: 1098027
Blocks: 878881
  Show dependency treegraph
 
Reported: 2012-10-10 09:50 EDT by robert.vanleeuwen
Modified: 2015-03-04 19:06 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-14 14:40:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description robert.vanleeuwen 2012-10-10 09:50:57 EDT
Description of problem:
Whenever an issue is found it shows up when execution the volume heal command, e.g. gluster volume heal <volume> info split-brain
This list is not cleared when the issue is resolved, only way to clear it is to restart glusterd on the affected node

Version-Release number of selected component (if applicable):
Tested on 3.3


Additional info:
Would make adding monitoring easier if this state is automatically cleared when all issues are resolved
Comment 1 Pierre-Francois Laquerre 2012-12-05 08:52:55 EST
Restarting glusterd doesn't solve this for me. The list is repopulated with the old split-brain logs after a few seconds. +1 on adding a clear feature.
Comment 2 Pranith Kumar K 2013-02-22 04:48:26 EST
*** Bug 871987 has been marked as a duplicate of this bug. ***
Comment 3 Pranith Kumar K 2013-03-22 01:50:21 EDT
*** Bug 905203 has been marked as a duplicate of this bug. ***
Comment 4 Anand Avati 2013-06-12 16:11:42 EDT
REVIEW: http://review.gluster.org/5209 (cluster/afr: Fix info split-brain's repetitive and redundant output) posted (#1) for review on master by venkatesh somyajulu (vsomyaju@redhat.com)
Comment 5 Niels de Vos 2014-11-27 09:54:00 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.
Comment 6 robert.vanleeuwen 2014-11-27 10:01:16 EST
I (original reporter) cannot confirm.

This issue was discovered with a test setup and we decided to use a different (now also Red Hat ;) product.

Note You need to log in before you can comment on or make changes to this bug.