Bug 872272 - Shim is not currently signed.
Shim is not currently signed.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: shim (Show other bugs)
18
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
:
: 882947 890840 (view as bug list)
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-01 13:10 EDT by Peter Jones
Modified: 2013-01-03 22:04 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 00:33:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Jones 2012-11-01 13:10:47 EDT
Description of problem: shim is not currently signed by the UEFI signing service.  That means new machines won't boot.
Comment 1 Adam Williamson 2012-11-01 14:28:26 EDT
Discussed at 2012-11-01 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-01/f18beta-blocker-review-6.5.2012-11-01-17.49.log.txt . Agreed this is rejected as a blocker as far as the blocker process goes: it is a conditional violation of "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods" in the case of an SB machine with SB enabled, but we don't believe those are yet prevalent enough to block a Beta release for. However, it's accepted as NTH, as it would be great to have the Beta SB testable OOTB.

Note that SB support is also a feature for F18, so FESCo could delay the release for this under the feature process. The feature process is separate from the blocker process by policy.
Comment 2 Jaroslav Reznik 2012-12-03 08:49:21 EST
*** Bug 882947 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-12-17 22:22:35 EST
shim-signed-0.2-3.2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/shim-signed-0.2-3.2.fc18
Comment 4 Fedora Update System 2012-12-18 16:28:25 EST
Package shim-signed-0.2-3.2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shim-signed-0.2-3.2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20583/shim-signed-0.2-3.2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-20 00:33:17 EST
shim-signed-0.2-3.2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Adam Williamson 2013-01-03 22:04:07 EST
*** Bug 890840 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.