Bug 872739 - AttributeError: 'NoneType' object has no attribute 'get'
AttributeError: 'NoneType' object has no attribute 'get'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:088a6508171aaff67a2ae0915b7...
: Reopened
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-02 17:04 EDT by Adam Williamson
Modified: 2013-01-02 18:35 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.24-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 15:03:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (315.83 KB, text/plain)
2012-11-02 17:04 EDT, Adam Williamson
no flags Details
File: product (6 bytes, text/plain)
2012-11-02 17:04 EDT, Adam Williamson
no flags Details
File: type (9 bytes, text/plain)
2012-11-02 17:04 EDT, Adam Williamson
no flags Details
File: ifcfg.log (661 bytes, text/plain)
2012-11-02 17:04 EDT, Adam Williamson
no flags Details
File: storage.log (131.36 KB, text/plain)
2012-11-02 17:04 EDT, Adam Williamson
no flags Details
File: version (2 bytes, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: environ (856 bytes, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: executable (14 bytes, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: anaconda.log (6.50 KB, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: syslog (109.83 KB, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: packaging.log (3.50 KB, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: cmdline_file (148 bytes, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: release (24 bytes, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
File: program.log (25.41 KB, text/plain)
2012-11-02 17:05 EDT, Adam Williamson
no flags Details
c24 anaconda.log (18.64 KB, text/plain)
2012-12-26 04:53 EST, Chris Murphy
no flags Details
c24 program.log (21.82 KB, text/plain)
2012-12-26 04:54 EST, Chris Murphy
no flags Details
c24 storage.log (73.73 KB, text/plain)
2012-12-26 04:55 EST, Chris Murphy
no flags Details
c24 storage.state (20.00 KB, text/plain)
2012-12-26 04:55 EST, Chris Murphy
no flags Details

  None (edit)
Description Adam Williamson 2012-11-02 17:04:49 EDT
Description of problem:
Tried to install to my Intel fwraid array, 2x80GB drives striped, with an image containing 18.23, parted 3.1-9, and dlehman's updates-intel-frwaid.0.img to fix the crash at the hub.

Version-Release number of selected component:
anaconda-18.23

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.5-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.23 exception report
:Traceback (most recent call first):
:  File "/tmp/updates/pyanaconda/storage/udev.py", line 148, in udev_device_get_uuid
:    md_uuid = udev_info.get("MD_UUID", '')
:  File "/tmp/updates/pyanaconda/storage/deviceaction.py", line 444, in execute
:    self.device.format.uuid = udev_device_get_uuid(info)
:  File "/tmp/updates/pyanaconda/storage/devicetree.py", line 323, in processActions
:    action.execute()
:  File "/tmp/updates/pyanaconda/storage/__init__.py", line 293, in doIt
:    self.devicetree.processActions()
:  File "/tmp/updates/pyanaconda/storage/__init__.py", line 131, in turnOnFilesystems
:    storage.doIt()
:  File "/tmp/updates/pyanaconda/install.py", line 113, in doInstall
:    turnOnFilesystems(storage)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/tmp/updates/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:AttributeError: 'NoneType' object has no attribute 'get'
Comment 1 Adam Williamson 2012-11-02 17:04:52 EDT
Created attachment 637247 [details]
File: anaconda-tb
Comment 2 Adam Williamson 2012-11-02 17:04:54 EDT
Created attachment 637248 [details]
File: product
Comment 3 Adam Williamson 2012-11-02 17:04:55 EDT
Created attachment 637249 [details]
File: type
Comment 4 Adam Williamson 2012-11-02 17:04:57 EDT
Created attachment 637250 [details]
File: ifcfg.log
Comment 5 Adam Williamson 2012-11-02 17:04:58 EDT
Created attachment 637251 [details]
File: storage.log
Comment 6 Adam Williamson 2012-11-02 17:05:00 EDT
Created attachment 637252 [details]
File: version
Comment 7 Adam Williamson 2012-11-02 17:05:01 EDT
Created attachment 637253 [details]
File: environ
Comment 8 Adam Williamson 2012-11-02 17:05:03 EDT
Created attachment 637254 [details]
File: executable
Comment 9 Adam Williamson 2012-11-02 17:05:04 EDT
Created attachment 637255 [details]
File: anaconda.log
Comment 10 Adam Williamson 2012-11-02 17:05:06 EDT
Created attachment 637256 [details]
File: syslog
Comment 11 Adam Williamson 2012-11-02 17:05:07 EDT
Created attachment 637257 [details]
File: hashmarkername
Comment 12 Adam Williamson 2012-11-02 17:05:09 EDT
Created attachment 637258 [details]
File: packaging.log
Comment 13 Adam Williamson 2012-11-02 17:05:13 EDT
Created attachment 637259 [details]
File: cmdline_file
Comment 14 Adam Williamson 2012-11-02 17:05:15 EDT
Created attachment 637260 [details]
File: release
Comment 15 Adam Williamson 2012-11-02 17:05:17 EDT
Created attachment 637261 [details]
File: program.log
Comment 16 Adam Williamson 2012-11-02 19:39:56 EDT
dlehman proposed this as Beta blocker - I should've done it earlier, sorry. It is a continuation of the problems with intel FW RAID installation: https://bugzilla.redhat.com/show_bug.cgi?id=866519 and https://bugzilla.redhat.com/show_bug.cgi?id=872361 . The bugs are getting filed separately, but it's all been one long process to get Intel fwRAID install to work. Marking this AcceptedBlocker as with the others.
Comment 17 Fedora Update System 2012-11-02 21:03:17 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 18 Fedora Update System 2012-11-03 15:27:54 EDT
Package anaconda-18.24-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.24-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17543/anaconda-18.24-1.fc18
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-11-05 20:38:28 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 20 Fedora Update System 2012-11-06 21:10:31 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 21 Adam Williamson 2012-11-07 14:21:00 EST
verified, TC7 is OK for this.
Comment 22 Fedora Update System 2012-11-07 22:24:47 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 23 Adam Williamson 2012-11-08 04:15:40 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).
Comment 24 Chris Murphy 2012-12-26 04:52:17 EST
Appears to not be entirely fixed, triggered this crash with anaconda-18.38.8-1 trying to work around Bug 890302 "cannot create boot mount point on existing Btrfs volume".

Steps to reproduce:
1. Btrfs volume, single disk. Existing boot and home subvols.
2. Manual Partitioning.
3. Set existing boot and home subvols to /boot and /home mount points.
4. Create new mount point Root.
5. Finish Partitioning
6. Begin Installation
Crash.

Setting back to assigned.
Comment 25 Chris Murphy 2012-12-26 04:53:51 EST
Created attachment 669147 [details]
c24 anaconda.log
Comment 26 Chris Murphy 2012-12-26 04:54:28 EST
Created attachment 669148 [details]
c24 program.log
Comment 27 Chris Murphy 2012-12-26 04:55:04 EST
Created attachment 669149 [details]
c24 storage.log
Comment 28 Chris Murphy 2012-12-26 04:55:46 EST
Created attachment 669150 [details]
c24 storage.state
Comment 29 Adam Williamson 2013-01-02 15:03:01 EST
Chris, your case is completely different to mine, which was a blocker because it was a showstopper for RAID installs. Can you file it separately, and include the traceback (anaconda-tb-foo) file too? The traceback is very important, we really need it.

If you think it constitutes a blocker, nominate the new bug as a blocker. Thanks.

(It looks like we could really stand to make libreport better at identifying dupes and not-dupes wrt anaconda...)
Comment 30 Chris Murphy 2013-01-02 18:35:48 EST
(In reply to comment #29)

Filed as bug 891443.

Note You need to log in before you can comment on or make changes to this bug.