Bug 873332 - AttributeError: 'NoneType' object has no attribute 'format'
AttributeError: 'NoneType' object has no attribute 'format'
Status: CLOSED DUPLICATE of bug 869839
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:a4ab6d505ec89a43931ee2681e4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-05 10:02 EST by wagerrard
Modified: 2012-11-05 14:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 14:05:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (387.54 KB, text/plain)
2012-11-05 10:02 EST, wagerrard
no flags Details
File: product (6 bytes, text/plain)
2012-11-05 10:02 EST, wagerrard
no flags Details
File: type (9 bytes, text/plain)
2012-11-05 10:02 EST, wagerrard
no flags Details
File: environ (780 bytes, text/plain)
2012-11-05 10:02 EST, wagerrard
no flags Details
File: storage.log (155.17 KB, text/plain)
2012-11-05 10:02 EST, wagerrard
no flags Details
File: version (2 bytes, text/plain)
2012-11-05 10:02 EST, wagerrard
no flags Details
File: program.log (60.81 KB, text/plain)
2012-11-05 10:02 EST, wagerrard
no flags Details
File: executable (14 bytes, text/plain)
2012-11-05 10:03 EST, wagerrard
no flags Details
File: anaconda.log (15.30 KB, text/plain)
2012-11-05 10:03 EST, wagerrard
no flags Details
File: syslog (115.73 KB, text/plain)
2012-11-05 10:03 EST, wagerrard
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-05 10:03 EST, wagerrard
no flags Details
File: packaging.log (4.29 KB, text/plain)
2012-11-05 10:03 EST, wagerrard
no flags Details
File: cmdline_file (87 bytes, text/plain)
2012-11-05 10:03 EST, wagerrard
no flags Details
File: release (24 bytes, text/plain)
2012-11-05 10:03 EST, wagerrard
no flags Details
File: ifcfg.log (1.10 KB, text/plain)
2012-11-05 10:03 EST, wagerrard
no flags Details

  None (edit)
Description wagerrard 2012-11-05 10:02:40 EST
Description of problem:
In Manual Partitioning.  Had just deleted the pre-existing filesystem by highlighting "Root", clicking the Minus icon, and answering "Yes" when prompted if I wanted to delete the entire filesystem.

That left a 1mb Root. I highlighted that, clicked the Minus icon, and the error appeared/


Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.2-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1670, in _destroy_device
:    if device.type == "partition" and device.disk.format.exists:
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1744, in on_remove_clicked
:    self._destroy_device(device)
:AttributeError: 'NoneType' object has no attribute 'format'
Comment 1 wagerrard 2012-11-05 10:02:43 EST
Created attachment 638682 [details]
File: anaconda-tb
Comment 2 wagerrard 2012-11-05 10:02:45 EST
Created attachment 638683 [details]
File: product
Comment 3 wagerrard 2012-11-05 10:02:47 EST
Created attachment 638684 [details]
File: type
Comment 4 wagerrard 2012-11-05 10:02:51 EST
Created attachment 638685 [details]
File: environ
Comment 5 wagerrard 2012-11-05 10:02:54 EST
Created attachment 638686 [details]
File: storage.log
Comment 6 wagerrard 2012-11-05 10:02:55 EST
Created attachment 638687 [details]
File: version
Comment 7 wagerrard 2012-11-05 10:02:57 EST
Created attachment 638688 [details]
File: program.log
Comment 8 wagerrard 2012-11-05 10:03:00 EST
Created attachment 638689 [details]
File: executable
Comment 9 wagerrard 2012-11-05 10:03:02 EST
Created attachment 638690 [details]
File: anaconda.log
Comment 10 wagerrard 2012-11-05 10:03:04 EST
Created attachment 638691 [details]
File: syslog
Comment 11 wagerrard 2012-11-05 10:03:07 EST
Created attachment 638692 [details]
File: hashmarkername
Comment 12 wagerrard 2012-11-05 10:03:10 EST
Created attachment 638693 [details]
File: packaging.log
Comment 13 wagerrard 2012-11-05 10:03:12 EST
Created attachment 638694 [details]
File: cmdline_file
Comment 14 wagerrard 2012-11-05 10:03:13 EST
Created attachment 638695 [details]
File: release
Comment 15 wagerrard 2012-11-05 10:03:15 EST
Created attachment 638696 [details]
File: ifcfg.log
Comment 16 Brian Lane 2012-11-05 14:05:42 EST
anaconda 18.19 is old, and this looks like a dupe of bug 869839

*** This bug has been marked as a duplicate of bug 869839 ***

Note You need to log in before you can comment on or make changes to this bug.