Bug 873361 - TypeError: cannot concatenate 'str' and 'NoneType' objects
TypeError: cannot concatenate 'str' and 'NoneType' objects
Status: CLOSED DUPLICATE of bug 873224
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-05 11:18 EST by Reartes Guillermo
Modified: 2012-11-05 11:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 11:43:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage.log (107.97 KB, text/plain)
2012-11-05 11:18 EST, Reartes Guillermo
no flags Details
anaconda.log (2.03 KB, text/plain)
2012-11-05 11:20 EST, Reartes Guillermo
no flags Details
program.log (37.23 KB, text/plain)
2012-11-05 11:20 EST, Reartes Guillermo
no flags Details
anaconda tb (251.42 KB, text/plain)
2012-11-05 11:21 EST, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-11-05 11:18:16 EST
Created attachment 638732 [details]
storage.log

Description of problem:

I boot the guest and it does never reaches the welcome screen.
The 'unknown error' screen is shown, but it later get covered by
the black screen and it is no longer possible to report the issue
via abrt.

Booting F18b TC6 on the very same guest works ok, one can reach
the welcome screen. With F18b TC7 one does not reach the welcome
screen.

Version-Release number of selected component (if applicable):
F18b TC7

How reproducible:
always

Steps to Reproduce:
1. boot F18b TC7
2. unknown error and black screen

  
Actual results:
F18b TC7 not reaching the welcome screen
F18b TC6 reaches the welcome screen

Expected results:
to reach the welcome screen (at least)

Additional info:
It is not possible to use ABRT due to it being covered by
a black screen after some seconds.
Comment 1 Reartes Guillermo 2012-11-05 11:20:15 EST
Created attachment 638733 [details]
anaconda.log
Comment 2 Reartes Guillermo 2012-11-05 11:20:43 EST
Created attachment 638734 [details]
program.log
Comment 3 Reartes Guillermo 2012-11-05 11:21:59 EST
Created attachment 638735 [details]
anaconda tb

anaconda 18.24 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 778, in addUdevMDDevice
    devicelibs.mdraid.mddeactivate("/dev/" + name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1058, in addUdevDevice
    device = self.addUdevMDDevice(info)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1902, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1850, in populate
    self._populate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 398, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 104, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: cannot concatenate 'str' and 'NoneType' objects
Comment 4 Reartes Guillermo 2012-11-05 11:28:57 EST
Maybe it is a dup of 873224
Comment 5 Chris Lumens 2012-11-05 11:43:38 EST

*** This bug has been marked as a duplicate of bug 873224 ***

Note You need to log in before you can comment on or make changes to this bug.