Bug 873509 - Selected message in editor should scroll fully into view
Selected message in editor should scroll fully into view
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
: 873956 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-05 23:41 EST by Yuko Katabami
Modified: 2013-02-25 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121113-0009)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuko Katabami 2012-11-05 23:41:15 EST
Created attachment 639076 [details]
zanata text field

Description of problem:
When I save one translated strings, cursor automatically moves to the next string below.
Position of the string is too low and sometimes a part of the text field is hidden behind TM/Glossary pane.

Version-Release number of selected component (if applicable): 2.0.2


How reproducible:
Always

Steps to Reproduce:
1.Save one string
2.Check the position of the text field.
3.
  
Actual results:
Too low

Expected results:
Has to be higher and show entire field.

Additional info:
screenshot attached
Comment 1 Sean Flanigan 2012-11-06 00:00:31 EST
We should probably autoscroll to make the current row fully visible, but aren't you able to scroll down manually?
Comment 2 Yuko Katabami 2012-11-06 00:10:34 EST
Yes, we can scroll down manually, and I do that each time, but this can be avoided if the position is right in the fist place. Previous version did not have this issue and did not require manual scrolling - editing field stayed around the middle. (so my hands can be on keyboard most of the time, instead of using mouse or trackpad to adjust the position every time).
As we work a few 100s+ strings each day, small things like this can make a difference. Hope it is not too complicated to fix.
Comment 3 Sean Flanigan 2012-11-07 01:09:31 EST
*** Bug 873956 has been marked as a duplicate of this bug. ***
Comment 4 Patrick Huang 2012-11-08 20:23:23 EST
committed into master and release:
https://github.com/zanata/zanata/commit/08e094ab09c3276f97be56997515d47fd99a76cb
Comment 5 Ding-Yi Chen 2012-11-13 03:12:54 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121112-1056) and Zanata version 2.1-SNAPSHOT (20121112-1056)

Note that just type any non-space characters if you find your cursor is to low to be seen.
Comment 6 Sean Flanigan 2012-11-26 23:21:58 EST
Both of the versions above are the same.  Was this tested against 2.0.x?
Comment 7 Ding-Yi Chen 2012-12-02 23:46:19 EST
It was tested against 2.0.3-SNAPSHOT (20121113-0009).

Note You need to log in before you can comment on or make changes to this bug.