Bug 873525 - unsaved indicator incorrect after first save or cancel
unsaved indicator incorrect after first save or cancel
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
development
Unspecified Unspecified
high Severity unspecified
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-06 01:10 EST by Patrick Huang
Modified: 2013-02-25 22:46 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121127-0017)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick Huang 2012-11-06 01:10:29 EST
Description of problem:
Unsaved indicator only works for first time. After saving a message, altering its content again will not compare it with latest saved content but the content when first loaded.

Version-Release number of selected component (if applicable):
2.0

How reproducible:
Always

Steps to Reproduce:
1. Go to translation editor
2. Find a message with translation, for example "foo"
3. Save as fuzzy
4. Change content from "foo" to "bar" (editor should indicate unsaved content)
5. Change content back from "bar" to "foo"
  
Actual results:
Unsaved indicator is still on

Expected results:
Unsaved indicator should be off since we have changed content back to latest saved value.

Additional info:
Comment 1 Patrick Huang 2012-11-06 01:15:20 EST
Correction of Steps to reproduce:
1. Go to translation editor
2. Find a message with translation, for example "foo"
3. Change it to "bar" and save as fuzzy
4. Change content from "bar" to "bar 1" (editor should indicate unsaved content)
5. Change content back from "bar 1" to "bar"


Also note:
If at any time press ESC to cancel edit, after that unsaved indicator will not function any more
Comment 2 Patrick Huang 2012-11-08 20:22:05 EST
committed into master and release:
https://github.com/zanata/zanata/commit/cd34f87e5d39804821b76274e69ec81951c6d4b8
Comment 4 Ding-Yi Chen 2012-11-27 01:20:32 EST
VERIFIED with Zanata version 2.0.3-SNAPSHOT (20121127-0017)
and Zanata version 2.1-SNAPSHOT (20121127-1134)

Note You need to log in before you can comment on or make changes to this bug.