Bug 873600 - errors are displayed inside installation source dialog, instead of the main hub screen
Summary: errors are displayed inside installation source dialog, instead of the main h...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 875008 877206 (view as bug list)
Depends On:
Blocks: F18-accepted, F18FinalFreezeExcept 873605
TreeView+ depends on / blocked
 
Reported: 2012-11-06 09:43 UTC by Kamil Páral
Modified: 2012-12-06 07:27 UTC (History)
4 users (show)

Fixed In Version: anaconda-18.33-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-06 07:27:39 UTC
Type: Bug


Attachments (Terms of Use)
anaconda1.png (57.02 KB, image/png)
2012-11-06 09:43 UTC, Kamil Páral
no flags Details
anaconda2.png (29.73 KB, image/png)
2012-11-06 09:44 UTC, Kamil Páral
no flags Details
18.34 hub (49.44 KB, image/png)
2012-12-03 15:33 UTC, Kamil Páral
no flags Details
18.34 source screen (27.25 KB, image/png)
2012-12-03 15:34 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2012-11-06 09:43:53 UTC
Created attachment 639225 [details]
anaconda1.png

Description of problem:
I set up an invalid NFS server, clicked Done. Then I waited, waited, waited... the items were gray and nothing happened at all (anaconda1.png). I believed it was frozen. Then I found out that I can click on the Installation Source dialog again and the error message is _inside_ it, instead on the main hub screen (anaconda2.png).

Version-Release number of selected component (if applicable):
anaconda 18.24

Steps to Reproduce:
1. provide invalid NFS server as installation source
2. wait on the main hub screen
  
Actual results:
no error displayed

Expected results:
error displayed

Comment 1 Kamil Páral 2012-11-06 09:44:13 UTC
Created attachment 639226 [details]
anaconda2.png

Comment 2 Chris Lumens 2012-11-06 17:02:56 UTC
The waiting and waiting is because of the timeout on NFS mounting.  I seem to remember a bug about that, but I'm having trouble finding it at the moment.  And then after that, we're just not handling the error correctly.  Looking into it.

Comment 3 Chris Lumens 2012-11-08 21:00:10 UTC
Testing the latest build, I am no longer seeing the behavior in image #1, though I am still seeing the very long delay.  Can you please verify?

Note that the patch we have for dealing with the delay appears to not be helping in this particular case.  Don't know what's going on with that yet.

Comment 4 Chris Lumens 2012-11-08 22:11:48 UTC
Oh, and I have a fix for the very long delay which I'll be shipping off right now.

Comment 5 Kamil Páral 2012-11-09 09:17:46 UTC
With anaconda 18.27 (smoke 16) I still see the same behavior. Installation source item is grayed out and doesn't contain an orange warning icon, but it can be clicked. The error line is displayed inside. Pixel perfect as previous screenshot, no change.

Reproducer:
1. Boot netinst
2. In installation source dialog, set nfs:server:/path, where server exists and is available over NFS protocol, but /path is nonexistent.
3. Tick "don't install updates".

Comment 6 Kamil Páral 2012-11-09 10:04:59 UTC
This also happens for installation repo http://aaaaa, not just NFS.

Comment 7 Chris Lumens 2012-11-09 15:20:47 UTC
Okay, will take another look.  The good news is there won't be any huge delay in testing the next release.  That fix has been pushed.

Comment 8 Fedora Update System 2012-11-10 00:56:42 UTC
anaconda-18.28-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18

Comment 9 Fedora Update System 2012-11-10 19:39:36 UTC
Package anaconda-18.28-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.28-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18
then log in and leave karma (feedback).

Comment 10 Kamil Páral 2012-11-12 11:28:58 UTC
Still the same in anaconda 18.28.

Comment 11 Chris Lumens 2012-11-12 16:04:57 UTC
Yes I know, we're just going to have to live with koji leaving those comments until the bug number gets removed from the update text.

Comment 12 Chris Lumens 2012-11-16 14:17:17 UTC
*** Bug 877206 has been marked as a duplicate of this bug. ***

Comment 13 Chris Lumens 2012-11-26 15:55:37 UTC
*** Bug 873605 has been marked as a duplicate of this bug. ***

Comment 14 Chris Lumens 2012-11-26 21:59:46 UTC
Finally, got a handle on this.  The commit that causes this behavior is 9dd7980575178d32ac90efb3c96b0b9f1113664e.

Comment 15 Chris Lumens 2012-11-27 18:55:26 UTC
*** Bug 875008 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2012-12-02 00:27:29 UTC
pykickstart-1.99.22-1.fc18, anaconda-18.34-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.34-1.fc18

Comment 17 Fedora Update System 2012-12-02 19:27:01 UTC
Package pykickstart-1.99.22-1.fc18, anaconda-18.34-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.22-1.fc18 anaconda-18.34-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.34-1.fc18
then log in and leave karma (feedback).

Comment 18 Kamil Páral 2012-12-03 15:33:06 UTC
Well, it's fixed, kind of. The hub icon is no longer gray, and it has a proper warning icon. But the bottom bar disappeared. The error is displayed fine inside the dialog.

Marking as VERIFIED, but it the bottom bar is supposed to be visible, something is still wrong here.

Comment 19 Kamil Páral 2012-12-03 15:33:50 UTC
Created attachment 656748 [details]
18.34 hub

Comment 20 Kamil Páral 2012-12-03 15:34:03 UTC
Created attachment 656749 [details]
18.34 source screen

Comment 21 Fedora Update System 2012-12-06 07:27:41 UTC
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.