This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 873817 - inkscape packaging bugs prevent install
inkscape packaging bugs prevent install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 891484 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-06 14:05 EST by Reartes Guillermo
Modified: 2013-01-15 07:28 EST (History)
17 users (show)

See Also:
Fixed In Version: inkscape-0.48.4-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-22 23:36:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (57.93 KB, image/png)
2012-11-06 14:23 EST, Reartes Guillermo
no flags Details
anacona.log (8.14 KB, text/plain)
2012-11-06 17:57 EST, Reartes Guillermo
no flags Details
syslog (61.61 KB, text/plain)
2012-11-06 17:58 EST, Reartes Guillermo
no flags Details
screenshot of the error (50.69 KB, image/png)
2012-12-16 12:18 EST, Reartes Guillermo
no flags Details
packaging.log (825.97 KB, text/plain)
2012-12-16 14:36 EST, Kamil Páral
no flags Details

  None (edit)
Description Reartes Guillermo 2012-11-06 14:05:23 EST
Description of problem:

It is not possible to install KDE Plasma Desktop + ALL ADDONS.
Installation stops with an error at package inkscape, but the
screen becomes all-black. 

packaging.log does not show any error, but it is the last package.

no anaconda-tb* file.


Version-Release number of selected component (if applicable):
F18b TC7

How reproducible:
always (should be easy)

Steps to Reproduce:

1. Enter STORAGE: INSTALLATION DESTINATION, select the disk
2. Do AUTOMATIC INSTALLATION, Type: PLAIN. (DELETE if necessary)
3. Change package group to KDE Plasma Workspaces and check all Addons
4. Begin Install, error when installing packages
  
Actual results:
installation ends at inkscape package

Expected results:
no error

Additional info:
Comment 1 Reartes Guillermo 2012-11-06 14:23:20 EST
Created attachment 639531 [details]
screenshot
Comment 2 Chris Lumens 2012-11-06 14:56:25 EST
Please attach /tmp/syslog and /tmp/anaconda.log to this bug report.
Comment 3 Reartes Guillermo 2012-11-06 17:57:53 EST
Created attachment 639686 [details]
anacona.log
Comment 4 Reartes Guillermo 2012-11-06 17:58:34 EST
Created attachment 639687 [details]
syslog
Comment 5 Jesse Keating 2012-11-06 19:53:58 EST
The packaging.log file would be useful too, trying to duplicate here.
Comment 6 Jesse Keating 2012-11-06 20:07:33 EST
Nevermind.  I was able to duplicate, there appears to be a problem with inkscape:

Installing inkscape-0.48.3.1-1.fc18.x86_64 (1093/1300)
error: unpacking of archive failed on file /usr/share/man/el/man1/inkscape.el.1.gz;5099b1f0: cpio: open failed - No such file or directory


Looking into it.
Comment 7 Jesse Keating 2012-11-07 00:08:24 EST
<nirik> -%{_mandir}/fr/man1/inkscape.1*
 +%{_mandir}/
 thats just wrong. ;( 

<kalev> it should probably use %find_lang --with-man, which generates the list of localized man pages, and also takes care of properly annotating the files with %lang()
* nirik nods. 
<nirik> could file a bug, but instead I'm having a beer. ;)
Comment 8 Jon Ciesla 2012-11-07 09:13:44 EST
I changed it to %find_lang %{name} --with-man, and it seems to make no difference, the el man page is present either way.  Maybe something else is wrong with inkscape, or I'm misunderstanding the problem?
Comment 9 Jesse Keating 2012-11-07 11:04:45 EST
(In reply to comment #8)
> I changed it to %find_lang %{name} --with-man, and it seems to make no
> difference, the el man page is present either way.  Maybe something else is
> wrong with inkscape, or I'm misunderstanding the problem?

Honestly, I don't know.  I didn't look into the package, just realized it wasn't something wrong anaconda was doing.
Comment 10 Jon Ciesla 2012-11-07 12:01:01 EST
Reartes, does increasing the RAM and/or disk available affect this at all?
Comment 11 Jesse Keating 2012-11-07 13:07:33 EST
(In reply to comment #10)
> Reartes, does increasing the RAM and/or disk available affect this at all?

I attempted installs where only inkscape was selected, and when a ton of other stuff was selected.  No difference.
Comment 12 Jon Ciesla 2012-11-07 14:46:49 EST
What about non-KDE spins?
Comment 13 Jesse Keating 2012-11-07 15:42:05 EST
Yeah, I did it from just a regular installer environment, not a live spin, and with kickstart just had inkscape selected, nothing else.
Comment 14 Jon Ciesla 2012-11-07 16:04:33 EST
Installing inkscape on a running system works fine, I wonder what's tripping this.
Comment 15 Jesse Keating 2012-11-07 16:12:49 EST
Maybe try installing in a fresh chroot where the chroot population package set is @core ?
Comment 16 Jon Ciesla 2012-11-08 09:32:16 EST
Just tried that on a fully updated f18 VM, and it went smoothly.
Comment 17 Andrew McNabb 2012-11-21 15:09:53 EST
I've come across this bug, too, with 18-Beta-RC1 and the current development/18 repository. I am not using any spins, but I have a kickstart script with a custom package list that includes inkscape. I am encountering basically the same error message as in Comment 6:

Installing inkscape-0.48.3.1-2.fc18.x86_64 (1376/3613)
error: unpacking of archive failed on file /usr/share/man/el/man1/inkscape.el.1.gz;50ad2ee6: cpio: open failed - No such file or directory

I tried copying over the RPM in a bash shell from the installer and running RPM manually:

rpm -ivh --root /mnt/sysimage inkscape-0.48.3.1-2.fc18.x86_64.rpm

This succeeded without any errors, so this makes me wonder whether it might possibly be a bug in Anaconda rather than Inkscape.
Comment 18 Andrew McNabb 2012-11-21 15:11:02 EST
By the way, anyone searching for this bug might find it useful if a comment includes the error message given by the Anaconda GUI:

"There was an error installing the inkscape package.  This is a fatal error and installation will be aborted."
Comment 19 mkruger 2012-12-01 23:50:16 EST
I got the same error as shown in comment 18. Here is some more information which I dug out of the console which may (or may not) be helpful:

Python callback <boundmethod RPMCallback.callback of <pyanaconda.packaging.yumpayload.RPMCallback object at 0xab76c32cc77>> failed, aborting

Pane is dead
Comment 20 Adam Williamson 2012-12-03 13:06:35 EST
Discussed at 2012-12-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-12-03/f18final-blocker-review-1.2.2012-12-03-17.25.log.txt . While this doesn't quite hit the existing criterion as written:

"There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"

we agreed in principle that it should be amended to cover any kind of critical packaging error which causes a package to fail to install, and on that basis, this bug is accepted as a blocker. We will draft up and finalize the criterion change on the test@ mailing list.
Comment 21 Jon Ciesla 2012-12-03 13:14:24 EST
Can anyone recreate this in a non-Anaconda situation?  That would be helpful in finding the issue.  Post-install package installation and chroot installation are OK.
Comment 22 Andrew McNabb 2012-12-03 14:13:29 EST
(In reply to comment #21)
> Can anyone recreate this in a non-Anaconda situation?  That would be helpful
> in finding the issue.  Post-install package installation and chroot
> installation are OK.

In Comment #17, I gave some evidence that this may be an Anaconda-specific problem.

(In reply to comment #20)
> we agreed in principle that it should be amended to cover any kind of
> critical packaging error which causes a package to fail to install, and on
> that basis, this bug is accepted as a blocker. We will draft up and finalize
> the criterion change on the test@ mailing list.

And by the way, it's not just that the package fails to install, but also that the installer gives up and quits when it hits this error.
Comment 23 Adam Williamson 2012-12-05 03:43:34 EST
andrew: that's actually more or less by design (it shouldn't outright *crash*, but it is in fact designed to just give up at that point), AIUI. the anaconda devs could give you the detailed explanation of why, but I believe it's basically that an error during package installation just should not happen, and if it does, that means something is very wrong: offering an option to just power on regardless could be making a bad situation worse. It's considered the best option to just give up and leave recovery to the user at that point.
Comment 24 Andrew McNabb 2012-12-05 10:00:39 EST
(In reply to comment #23)
> andrew: that's actually more or less by design (it shouldn't outright
> *crash*, but it is in fact designed to just give up at that point), AIUI.
> the anaconda devs could give you the detailed explanation of why, but I
> believe it's basically that an error during package installation just should
> not happen, and if it does, that means something is very wrong: offering an
> option to just power on regardless could be making a bad situation worse.
> It's considered the best option to just give up and leave recovery to the
> user at that point.

I guess that makes sense.

In any case, Anaconda crashes, but Yum doesn't.
Comment 25 Jaroslav Reznik 2012-12-06 06:04:57 EST
Isn't this one related to the man-pages-de bug - https://bugzilla.redhat.com/show_bug.cgi?id=878967 - so the wrong directory ownership - https://bugzilla.redhat.com/show_bug.cgi?id=569392 and %{_mandir}/?
Comment 26 Jon Ciesla 2012-12-06 11:36:58 EST
Good eye.  If that's correct, the forthcoming update should fix this.
Comment 27 Fedora Update System 2012-12-06 11:38:06 EST
inkscape-0.48.3.1-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/inkscape-0.48.3.1-4.fc18
Comment 28 Fedora Update System 2012-12-06 15:18:31 EST
Package inkscape-0.48.3.1-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing inkscape-0.48.3.1-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19872/inkscape-0.48.3.1-4.fc18
then log in and leave karma (feedback).
Comment 29 Fedora Update System 2012-12-15 16:27:47 EST
inkscape-0.48.3.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 30 Kamil Páral 2012-12-16 11:50:39 EST
Can somebody please verify this is fixed with the new version? Thank you!
Comment 31 Reartes Guillermo 2012-12-16 12:18:22 EST
Created attachment 664385 [details]
screenshot of the error

Selected KDE and all addons.
It failed when installed inkscape.

No unknown error was issued, the screen remained all-black.
No anaconfa-tb-XXX file was generated.

Tested with F18 TC2 (18.37.2)
Comment 32 Kamil Páral 2012-12-16 14:36:31 EST
Created attachment 664474 [details]
packaging.log

I can confirm the problem with F18 TC2 DVD i386. It contains inkscape-0.48.3.1-4.fc18. In my case, I received a screen same as in attachment 639531 [details]. I guess it's a probably race condition with gtk thread whether you received a black screen or not.

Quite interestingly, the error is not included in the packaging.log. Neither it is on any tty. I wonder why Reartes see it and I don't.
Comment 33 Reartes Guillermo 2012-12-16 14:47:49 EST
@Kamil Páral

There is a (randomly named) tmpXXXX file in /ymp. (some sort of buffer?).
The screen-shot i uploaded is from that file.
Comment 34 Reartes Guillermo 2012-12-16 14:48:18 EST
@Kamil Páral

CORRECTED COMMENT

There is a (randomly named) tmpXXXX file in /tmp. (some sort of buffer?).
The screen-shot i uploaded is from that file.
Comment 35 Michael Schwendt 2012-12-18 03:34:32 EST
In case the last commit was supposed to fix something related to man page dir ownership, it was a half-hearted fix,
http://lists.fedoraproject.org/pipermail/scm-commits/2012-December/911922.html
because the packages still owns several man page dirs:

$ rpmlsv -p inkscape-0.48.3.1-4.fc18.x86_64.rpm|grep /man
drwxr-xr-x root  root         0 /usr/share/man/el/man1
-rw-r--r-- root  root     15160 /usr/share/man/el/man1/inkscape.el.1.gz
drwxr-xr-x root  root         0 /usr/share/man/fr/man1
-rw-r--r-- root  root     12860 /usr/share/man/fr/man1/inkscape.fr.1.gz
drwxr-xr-x root  root         0 /usr/share/man/ja/man1
-rw-r--r-- root  root     13076 /usr/share/man/ja/man1/inkscape.ja.1.gz
-rw-r--r-- root  root     11625 /usr/share/man/man1/inkscape.1.gz
-rw-r--r-- root  root     15160 /usr/share/man/man1/inkscape.el.1.gz
-rw-r--r-- root  root     12860 /usr/share/man/man1/inkscape.fr.1.gz
-rw-r--r-- root  root     13076 /usr/share/man/man1/inkscape.ja.1.gz
-rw-r--r-- root  root     12541 /usr/share/man/man1/inkscape.sk.1.gz
-rw-r--r-- root  root     12240 /usr/share/man/man1/inkscape.zh_TW.1.gz
drwxr-xr-x root  root         0 /usr/share/man/sk/man1
-rw-r--r-- root  root     13076 /usr/share/man/sk/man1/inkscape.ja.1.gz
drwxr-xr-x root  root         0 /usr/share/man/zh_TW/man1
-rw-r--r-- root  root     12240 /usr/share/man/zh_TW/man1/inkscape.zh_TW.1.gz
Comment 36 Adam Williamson 2012-12-18 03:43:37 EST
ah, that's likely the problem, yes. it should not own any.
Comment 37 Michael Schwendt 2012-12-18 03:49:46 EST
# repoquery --whatprovides /usr/share/man/el
wesnoth-data-0:1.10.5-1.fc18.noarch
filesystem-0:3.1-2.fc18.x86_64
wesnoth-data-0:1.10.5-1.fc18.noarch

# repoquery --whatprovides /usr/share/man/el/*
filesystem-0:3.1-2.fc18.x86_64
inkscape-0:0.48.3.1-4.fc18.x86_64
inkscape-0:0.48.3.1-4.fc18.x86_64
Comment 38 Jon Ciesla 2012-12-18 13:25:06 EST
Fixed in the next build.
Comment 39 Fedora Update System 2012-12-18 13:47:28 EST
inkscape-0.48.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/inkscape-0.48.4-1.fc17
Comment 40 Fedora Update System 2012-12-18 13:47:48 EST
inkscape-0.48.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/inkscape-0.48.4-1.fc18
Comment 41 Fedora Update System 2012-12-18 13:48:12 EST
inkscape-0.48.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/inkscape-0.48.4-1.fc16
Comment 42 Fedora Update System 2012-12-19 03:37:29 EST
Package inkscape-0.48.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing inkscape-0.48.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20620/inkscape-0.48.4-1.fc17
then log in and leave karma (feedback).
Comment 43 Michael Schwendt 2012-12-19 16:55:12 EST
> -%{_mandir}/*/*
> +%{_mandir}/*/*gz
> +%{_mandir}/*/*/*gz

;-)

Considering that all the man pages are for the "inkscape" executable, you could have used

  inkscape*.1*  

or even

  man1/inkscape*.1*

instead of

  *gz

and from the packaging hints department store, it's possible to add files to a package with the %files -f option and e.g. use a matching "find -type f …" command to only add man pages it finds. No risk of adding any directories that way.
Comment 44 Adam Williamson 2012-12-19 18:44:19 EST
We're waiting for the updated package to hit mirrors before we can test this.
Comment 45 Fedora Update System 2012-12-20 11:06:21 EST
inkscape-0.48.3.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 46 Kamil Páral 2012-12-21 07:00:40 EST
The problem is fixed with inkscape-0.48.4-1.fc18. We need to push it stable.
Comment 47 Fedora Update System 2012-12-22 23:36:40 EST
inkscape-0.48.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 48 Fedora Update System 2013-01-05 01:48:19 EST
inkscape-0.48.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 49 Fedora Update System 2013-01-05 01:54:32 EST
inkscape-0.48.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 50 Jon Ciesla 2013-01-15 07:28:29 EST
*** Bug 891484 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.