Bug 873852 - anaconda 'storage: installation destination' must be re-validated when switching software groups (specially from the smallest to the biggest)
anaconda 'storage: installation destination' must be re-validated when switch...
Status: CLOSED DUPLICATE of bug 853636
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-06 15:11 EST by Reartes Guillermo
Modified: 2012-12-11 13:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 13:16:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2012-11-06 15:11:44 EST
Description of problem:

Anaconda seems to not to have realized that the space requirements
have changed, while 'minimal' happily lives in 1gb, gnome will 
certainly do not. (even Automatic Partitioning chooses such small 
partitions for / when 'minimal' is selected, on some occasions, even
for bigger disks).

Version-Release number of selected component (if applicable):
F18b TC7

How reproducible:
always, but use a small disks guest (3gb disk)

Steps to Reproduce:

0. Boot and select the 'minimal' Software Group

1. Enter STORAGE: INSTALLATION DESTINATION and do MANUAL PARTITIONING with Type set to: PLAIN (others are untested  yet for this)

2. Create these following partitions: (3g disk)

* /boot 512mb
* SWAP  256mb
* /       1gb

3. Finish Partitioning, in the MAIN HUB the 'begin installation' button is unlocked. This will normally work, but we will do other nasty stuff to make it fail. :-) 

4. Change the Software Group from 'minimal' to 'gnome' (for example)

5. 'begin installation'


Actual results:
could not run transaction, and ABRT will hit another bugreport.

Expected results:
anaconda should invalidate previous storage selection, since it is no longer valid. 

Additional info:
Comment 1 Chris Lumens 2012-12-11 13:16:40 EST

*** This bug has been marked as a duplicate of bug 853636 ***

Note You need to log in before you can comment on or make changes to this bug.