This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 853636 - poor checking of storage config against software set space needs
poor checking of storage config against software set space needs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:12d779e671efd28070ce3591644...
: Reopened
: 873852 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-09-01 12:22 EDT by Flóki Pálsson
Modified: 2013-03-26 20:20 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 20:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: ifcfg.log (687 bytes, text/plain)
2012-09-01 12:22 EDT, Flóki Pálsson
no flags Details
File: anaconda-tb (658.53 KB, text/plain)
2012-09-01 12:22 EDT, Flóki Pálsson
no flags Details
File: environ (760 bytes, text/plain)
2012-09-01 12:22 EDT, Flóki Pálsson
no flags Details
File: type (9 bytes, text/plain)
2012-09-01 12:22 EDT, Flóki Pálsson
no flags Details
File: storage.log (318.52 KB, text/plain)
2012-09-01 12:22 EDT, Flóki Pálsson
no flags Details
File: version (12 bytes, text/plain)
2012-09-01 12:23 EDT, Flóki Pálsson
no flags Details
File: program.log (117.43 KB, text/plain)
2012-09-01 12:23 EDT, Flóki Pálsson
no flags Details
File: product (6 bytes, text/plain)
2012-09-01 12:23 EDT, Flóki Pálsson
no flags Details
File: syslog (131.59 KB, text/plain)
2012-09-01 12:23 EDT, Flóki Pálsson
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-01 12:23 EDT, Flóki Pálsson
no flags Details
File: anaconda.log (28.95 KB, text/plain)
2012-09-01 12:23 EDT, Flóki Pálsson
no flags Details
File: release (24 bytes, text/plain)
2012-09-01 12:23 EDT, Flóki Pálsson
no flags Details
File: description (636 bytes, text/plain)
2012-09-01 12:23 EDT, Flóki Pálsson
no flags Details
snapshot, during root password (74.43 KB, image/png)
2012-10-09 21:14 EDT, Reartes Guillermo
no flags Details
anaconda.log (18.16) (10.24 KB, text/plain)
2012-10-14 18:15 EDT, Steve Tyler
no flags Details
ifcfg.log (18.16) (641 bytes, text/plain)
2012-10-14 18:17 EDT, Steve Tyler
no flags Details
packaging.log (18.16) (4.97 KB, text/plain)
2012-10-14 18:17 EDT, Steve Tyler
no flags Details
program.log (18.16) (35.22 KB, text/plain)
2012-10-14 18:18 EDT, Steve Tyler
no flags Details
storage.log (18.16) (92.99 KB, text/plain)
2012-10-14 18:19 EDT, Steve Tyler
no flags Details
syslog (18.16) (71.72 KB, text/plain)
2012-10-14 18:19 EDT, Steve Tyler
no flags Details
X.log (18.16) (55.23 KB, text/plain)
2012-10-14 18:20 EDT, Steve Tyler
no flags Details
ps-ef-1.txt ("ps -ef" after screen went black; 18.16) (5.30 KB, text/plain)
2012-10-14 18:37 EDT, Steve Tyler
no flags Details
storage.log (228.56 KB, text/plain)
2012-11-04 14:57 EST, Reartes Guillermo
no flags Details

  None (edit)
Description Flóki Pálsson 2012-09-01 12:22:44 EDT
Description of problem:


Version-Release number of selected component:
anaconda-18.6.4

Additional info:
libreport version: 2.0.12
cmdline:        initrd=initrd.img  quiet rd.live.check BOOT_IMAGE=vmlinuz 
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64
Comment 1 Flóki Pálsson 2012-09-01 12:22:46 EDT
Created attachment 608916 [details]
File: ifcfg.log
Comment 2 Flóki Pálsson 2012-09-01 12:22:51 EDT
Created attachment 608917 [details]
File: anaconda-tb
Comment 3 Flóki Pálsson 2012-09-01 12:22:53 EDT
Created attachment 608918 [details]
File: environ
Comment 4 Flóki Pálsson 2012-09-01 12:22:55 EDT
Created attachment 608919 [details]
File: type
Comment 5 Flóki Pálsson 2012-09-01 12:22:58 EDT
Created attachment 608920 [details]
File: storage.log
Comment 6 Flóki Pálsson 2012-09-01 12:23:00 EDT
Created attachment 608921 [details]
File: version
Comment 7 Flóki Pálsson 2012-09-01 12:23:02 EDT
Created attachment 608922 [details]
File: program.log
Comment 8 Flóki Pálsson 2012-09-01 12:23:04 EDT
Created attachment 608923 [details]
File: product
Comment 9 Flóki Pálsson 2012-09-01 12:23:06 EDT
Created attachment 608924 [details]
File: syslog
Comment 10 Flóki Pálsson 2012-09-01 12:23:08 EDT
Created attachment 608925 [details]
File: hashmarkername
Comment 11 Flóki Pálsson 2012-09-01 12:23:10 EDT
Created attachment 608926 [details]
File: anaconda.log
Comment 12 Flóki Pálsson 2012-09-01 12:23:12 EDT
Created attachment 608927 [details]
File: release
Comment 13 Flóki Pálsson 2012-09-01 12:23:14 EDT
Created attachment 608928 [details]
File: description
Comment 14 Chris Lumens 2012-09-01 13:16:46 EDT
PackageSackError: <class 'yum.Errors.PackageSackError'>
YumBaseError: <class 'yum.Errors.YumBaseError'>
error: ('installing package kernel-3.6.0-0.rc2.git2.1.fc18.x86_64 needs 250MB on the / filesystem', (9, '/', 262017024L))
script_log: <closed file '<fdopen>', mode 'w+b' at 0x47d5390>
YumRPMTransError: <class 'yum.Errors.YumRPMTransError'>
rpmcb: <pyanaconda.packaging.yumpayload.RPMCallback object at 0x440e090>
Comment 15 Martin Banas 2012-10-03 09:57:35 EDT
1. Start installation
2. Proceed to main hub
3. Select partitioning, create custom partitioning
4. Let anaconda create basic partitioning for you
5. Resize / partition to 2GB
6. Proceed with installation
7. Traceback while preparing transaction


Package: anaconda-18.11
OS Release: Fedora release 18-Beta-TC1
Comment 16 Chuck Forsberg 2012-10-04 11:42:12 EDT
Happened while preparing transaction from installation source tc1 netinst 64 bit

Package: anaconda-18.11
OS Release: Fedora release 18-Beta-TC1
Comment 17 David Lehman 2012-10-04 12:13:31 EDT
Original reporter had a 500MB root filesystem. The payload's space requirement was around 650MB. We need to make sure we're updating the space check whenever software selection or storage setup changes.
Comment 18 Peter Robinson 2012-10-06 07:42:02 EDT
Just trying to install a standard gnome install on a KVM VM using all defaults for partitioning etc

Package: anaconda-18.12
OS Release: Fedora release 18-Beta-TC2
Comment 19 Reartes Guillermo 2012-10-09 21:03:56 EDT
set KDE desktop
set argentina / buenos aires (no ntp)
set keyboard spanish
and then i reclaimed space deleting previous fedora install, (or at leas i belive to have done so)


Package: anaconda-18.14
OS Release: Fedora release 18-Beta-TC3
Comment 20 Reartes Guillermo 2012-10-09 21:14:30 EDT
Created attachment 624390 [details]
snapshot, during root password
Comment 21 Steve Tyler 2012-10-14 17:48:49 EDT
attempting to reproduce bug 866204
using clean, default, minimal f16 install as starting point
first attempt resulted in a black display; anaconda, x gone
restarted without cleaning up the target disc image


Package: anaconda-18.16
OS Release: Fedora release 18-Beta-TC4
Comment 22 Steve Tyler 2012-10-14 18:15:32 EDT
Created attachment 627144 [details]
anaconda.log (18.16)
Comment 23 Steve Tyler 2012-10-14 18:17:01 EDT
Created attachment 627145 [details]
ifcfg.log (18.16)
Comment 24 Steve Tyler 2012-10-14 18:17:34 EDT
Created attachment 627146 [details]
packaging.log (18.16)
Comment 25 Steve Tyler 2012-10-14 18:18:17 EDT
Created attachment 627147 [details]
program.log (18.16)
Comment 26 Steve Tyler 2012-10-14 18:19:07 EDT
Created attachment 627148 [details]
storage.log (18.16)
Comment 27 Steve Tyler 2012-10-14 18:19:48 EDT
Created attachment 627149 [details]
syslog (18.16)
Comment 28 Steve Tyler 2012-10-14 18:20:25 EDT
Created attachment 627150 [details]
X.log (18.16)
Comment 29 Steve Tyler 2012-10-14 18:37:20 EDT
Created attachment 627151 [details]
ps-ef-1.txt ("ps -ef" after screen went black; 18.16)

(In reply to comment #21)
> attempting to reproduce bug 866204
> using clean, default, minimal f16 install as starting point
> first attempt resulted in a black display; anaconda, x gone
> restarted without cleaning up the target disc image
> 
> 
> Package: anaconda-18.16
> OS Release: Fedora release 18-Beta-TC4

I was mistaken. Xorg is running. anaconda and metacity are not.

Both /mnt/sysimage/etc/ and /mnt/sysimage/boot/ have F16 files:

$ cat etc-fedora-release-1.txt
Fedora release 16 (Verne)

$ cat ls-lF-boot-1.txt 
total 19832
-rw-------. 1 root root  2458775 Nov  1  2011 System.map-3.1.0-7.fc16.x86_64
-rw-r--r--. 1 root root   118511 Nov  1  2011 config-3.1.0-7.fc16.x86_64
drwxr-xr-x. 2 root root     1024 Oct 14 21:59 grub/
drwxr-xr-x. 3 root root     7168 Oct 14 22:01 grub2/
-rw-r--r--. 1 root root 13575517 Oct 14 22:00 initramfs-3.1.0-7.fc16.x86_64.img
drwx------. 2 root root    12288 Oct 14 21:57 lost+found/
-rwxr-xr-x. 1 root root  4125616 Nov  1  2011 vmlinuz-3.1.0-7.fc16.x86_64*

Reproduced twice.
Comment 30 Reartes Guillermo 2012-11-04 14:54:43 EST
i tried automatic partitioning type btrfs ona a preexisting dualboot guest
choose preserve for the ntfs, and delete for the others except shrink for the last
i noticed that a previous biosboot partition was incorrecly show as a previous /, maybe
anaconda mistook it for the /  filesystem (for which i choose shrink)


Package: anaconda-18.24
OS Release: Fedora release 18-Beta-TC7
Comment 31 Reartes Guillermo 2012-11-04 14:57:49 EST
Created attachment 638147 [details]
storage.log
Comment 32 David Lehman 2012-11-05 10:03:04 EST
(In reply to comment #30)
> i tried automatic partitioning type btrfs ona a preexisting dualboot guest
> choose preserve for the ntfs, and delete for the others except shrink for
> the last
> i noticed that a previous biosboot partition was incorrecly show as a
> previous /, maybe
> anaconda mistook it for the /  filesystem (for which i choose shrink)
> 

This is not at all related to the bug in which you are reporting it. Please open a new bug report for your issue.
Comment 33 Steve Tyler 2012-11-05 11:18:47 EST
(In reply to comment #32)
> (In reply to comment #30)
> > i tried automatic partitioning type btrfs ona a preexisting dualboot guest
> > choose preserve for the ntfs, and delete for the others except shrink for
> > the last
> > i noticed that a previous biosboot partition was incorrecly show as a
> > previous /, maybe
> > anaconda mistook it for the /  filesystem (for which i choose shrink)
> > 
> 
> This is not at all related to the bug in which you are reporting it. Please
> open a new bug report for your issue.

These strings in Comment 30 indicate a software-assisted bug report that was classified as a duplicate of this bug report:

Package: anaconda-18.24
OS Release: Fedora release 18-Beta-TC7

See also: Comment 15, Comment 16, Comment 18, Comment 19, Comment 21

OT Comment: These mini-reports need to be better identified. What would you like to see them contain?
Comment 34 Reartes Guillermo 2012-11-06 11:07:51 EST
i believe that it happened because i choose minimal, select a disks with free space and then went again and selected kde with all addons, hoping that the 'plenty of free space' was refering to minimal. All was ok in the main hub, so i started installing and kaboooom. Maybe i was right.

Package: anaconda-18.24
OS Release: Fedora release 18-Beta-TC7
Comment 35 Reartes Guillermo 2012-11-06 11:12:02 EST
@David Lehman

Please note that both comment #34 and #30 were done by ABRT. (I attached the log manually to #31 later).
Comment 36 Steve Tyler 2012-11-11 08:54:52 EST
Attempting to reproduce Bug 875422.

Package: anaconda-18.28
OS Release: Fedora release 18-Beta-TC8
Comment 37 Chris Lumens 2012-12-11 13:16:40 EST
*** Bug 873852 has been marked as a duplicate of this bug. ***
Comment 38 Fedora Update System 2012-12-11 19:54:29 EST
anaconda-18.37.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
Comment 39 Karel Volný 2012-12-12 08:28:02 EST
I've just tried to install F18 ... I guess the installer shouldn't just stop working here without giving any chance to retry ..

Package: anaconda-18.36
OS Release: Fedora release 18
Comment 40 Karel Volný 2012-12-12 08:30:19 EST
(In reply to comment #39)
> I've just tried to install F18 ... I guess the installer shouldn't just stop
> working here without giving any chance to retry ..
> 
> Package: anaconda-18.36
> OS Release: Fedora release 18

hm, I'm not sure if abrt chosen the right bug to append a dupe to, but I really do not have problems with space in / ... my root partition is about 600 GiB big!
Comment 41 Adam Williamson 2012-12-12 13:35:09 EST
Discussed at 2012-12-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-12/f18final-blocker-review-4.2012-12-12-17.01.log.txt . Accepted as a blocker per criterion "The installer's custom partitioning mode must be capable of the following ... Rejecting obviously invalid operations without crashing".
Comment 42 Fedora Update System 2012-12-12 15:41:14 EST
Package anaconda-18.37.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
then log in and leave karma (feedback).
Comment 43 Fedora Update System 2012-12-14 22:17:32 EST
anaconda-18.37.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 44 Kamil Páral 2012-12-16 11:49:54 EST
Can somebody please verify this is fixed with the new version? Thank you!
Comment 45 Martin Banas 2012-12-17 03:39:55 EST
Hi Kamil,

I'm not able to reproduce this, since anaconda now doesn't allow me to continue with only 2GB on / partition (comment 15). Checking seems to be OK, I tried the exact size of / which anaconda told me is required and it worked.

Tested on Fedora-18-TC2
Comment 46 Kamil Páral 2012-12-17 03:44:53 EST
Great, thanks Martin. Closing.
Comment 47 Pavel Šimerda (pavlix) 2012-12-21 15:12:39 EST
(In reply to comment #39)
> I've just tried to install F18 ... I guess the installer shouldn't just stop
> working here without giving any chance to retry ..
> 
> Package: anaconda-18.36
> OS Release: Fedora release 18

Agreed.

Plus when anaconda doesn't find a package (cracklib-dicts in my case), it allows to file a bug report and it says it would be duplicate to this one. That looks completely broken.
Comment 48 Alan Milnes 2013-03-13 10:38:29 EDT
Have just hit this problem in F18 using the DVD installer.
Comment 49 Adam Williamson 2013-03-13 18:42:23 EDT
I don't see a comment from libreport saying you hit this bug, which makes me sceptical that you actually hit what was fixed in this report. Could you please provide more details and, ideally, logs? Thanks.
Comment 50 Alan Milnes 2013-03-13 20:31:11 EDT
Hi Adam I think you are right, have used this DVD a few times and it has been fine.  After hitting this issue twice today I noticed some marks on the DVD, cut a new one and it worked fine. 

Thanks!
Comment 51 Adam Williamson 2013-03-13 20:56:10 EDT
OK, so let's close this again.
Comment 52 schaefi 2013-03-26 19:52:07 EDT
I have hit this bug today. Logfiles should be provided in the automatic bug report.
Comment 53 schaefi 2013-03-26 20:20:09 EDT
(In reply to comment #52)
> I have hit this bug today. Logfiles should be provided in the automatic bug
> report.

After reading the comments closely, I also checked my installation media.
The instalation check of the DVD failed! 
So this is not a Fedora bug.

Note You need to log in before you can comment on or make changes to this bug.