Bug 873930 - Properties/XLIFF strategies should check source content when pushing
Properties/XLIFF strategies should check source content when pushing
Status: CLOSED DUPLICATE of bug 873489
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos Munoz
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-06 21:02 EST by Sean Flanigan
Modified: 2013-12-11 23:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 23:00:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-11-06 21:02:13 EST
Description of problem:

When pushing translated content in Properties projects, we don't check whether the client's source files are up to date.

Version-Release number of selected component (if applicable):
2.0.2

How reproducible:


Steps to Reproduce:
1. Push source v1:
greeting=Hello

2. Push source v2:
greeting=Hello World

3. Revert source v2 to v1, and push trans v1:
greeting=Hallo
  
Actual results:
"Hallo" is accepted as a translation of "Hello World".  (It is actually a translation of source v1, "Hello".)

Expected results:
"Hallo Welt" is rejected by the server because the latest version of greeting is "Hello World", not "Hello".


Additional info:

See also bug 873500.

I think we can solve this by allowing the client to push a hash of the source content as an optional property of the TextFlowTarget DTO.  If it is provided, the server can check this against the HTextFlow's contentHash, and decide whether to accept the translation or reject it.
Comment 1 Sean Flanigan 2013-12-11 23:00:41 EST

*** This bug has been marked as a duplicate of bug 873489 ***

Note You need to log in before you can comment on or make changes to this bug.