This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 873971 - [virtio-win][serial]Sleep and Hibernate will stop virtio serial device [view the status from device manager]
[virtio-win][serial]Sleep and Hibernate will stop virtio serial device [view ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: Regression
: 882117 (view as bug list)
Depends On:
Blocks: 873960 877333
  Show dependency treegraph
 
Reported: 2012-11-07 01:54 EST by dengmin
Modified: 2013-02-21 05:41 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:41:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of Device (116.55 KB, image/png)
2012-11-07 01:54 EST, dengmin
no flags Details

  None (edit)
Description dengmin 2012-11-07 01:54:43 EST
Created attachment 639853 [details]
Screenshot of Device

Description of problem:
Install virtio serial driver to the guest and do S3 and S4 (just enable the driver and no data is transferring between guest and host)

How reproducible:
3 times 3 failed 

Steps to Reproduce:
1.boot up guest 
  /usr/libexec/qemu-kvm -m 4G -smp 4 -usb -device usb-tablet,id=tablet0 -drive file=win7-64-run.raw,if=none,id=drive-virtio0-0-0,format=raw,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-virtio0-0-0,id=virti0-0-0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device rtl8139,netdev=hostnet0,id=net0,mac=00:12:10:94:a3:f8 -uuid 8677bf9b-3cf6-47a1-b3e9-94213b801c87 -monitor stdio -spice id=on,disable-ticketing,port=5912 -vga qxl -device virtio-serial-pci,id=virtio-serial0,max_ports=16 -chardev socket,id=channel0,path=/tmp/helloworld,server,nowait -device virtserialport,nr=2,chardev=channel0,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port0 -device virtio-serial-pci,id=virtio-serial1,max_ports=31 -chardev socket,id=channel1,path=/tmp/helloworld1,server,nowait -device virtserialport,nr=2,chardev=channel1,name=com.redhat.rhevm.vdsm1,bus=virtio-serial1.0,id=port1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -device virtio-balloon-pci,addr=0x6,bus=pci.0,id=balloon1 
2. do S3 or S4 [need to install qxl driver]
3. resume the guest.

Actual results:
The guest can be resumed successfully but the serial device status is "stop" on device manager.Please see screenshot.
Expected results:
The guest is resumed successfully.

Additional info:
Comment 7 dengmin 2012-11-18 22:39:38 EST
Hi all,

   Re-test the bug ,and find the build is broken since build 42 comes out,any issues please let me know.

Thanks 
Min
Comment 10 Mike Cao 2012-11-19 06:57:43 EST
Reproduced on virtio-win-prewhql-43
Verified this issue on virtio-prewhql-45

Steps same as comment #0

Actual Results:
on build 43,serial device status is "stop"
on build 45,serial device works fine 

Based on above ,this issue has been fixed ald 
move status to verified.
Comment 11 Mike Cao 2012-12-06 00:20:23 EST
*** Bug 882117 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2013-02-21 05:41:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.