Bug 874042 - [abrt] xfce4-cellmodem-plugin-0.0.5-7.fc17: cellmodem_t_delete: Process /usr/libexec/xfce4/panel-plugins/xfce4-cellmodem-plugin was killed by signal 11 (SIGSEGV)
Summary: [abrt] xfce4-cellmodem-plugin-0.0.5-7.fc17: cellmodem_t_delete: Process /usr/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-cellmodem-plugin
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:320863164bcd64ab5a869b325c9...
: 602662 651196 910993 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-07 11:03 UTC by Jani Heinonen
Modified: 2013-02-28 07:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-28 07:08:40 UTC


Attachments (Terms of Use)
File: var_log_messages (190 bytes, text/plain)
2012-11-07 11:03 UTC, Jani Heinonen
no flags Details
File: core_backtrace (284 bytes, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: environ (1.31 KB, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: backtrace (18.80 KB, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: cgroup (128 bytes, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: smolt_data (2.70 KB, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: executable (55 bytes, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: maps (23.65 KB, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: dso_list (4.92 KB, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: proc_pid_status (930 bytes, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details
File: open_fds (234 bytes, text/plain)
2012-11-07 11:04 UTC, Jani Heinonen
no flags Details


Links
System ID Priority Status Summary Last Updated
Xfce 6747 None None None Never

Description Jani Heinonen 2012-11-07 11:03:56 UTC
Description of problem:
Removed app from panel

Version-Release number of selected component:
xfce4-cellmodem-plugin-0.0.5-7.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/libexec/xfce4/panel-plugins/xfce4-cellmodem-plugin '' 2 20995240 cellmodem 'Cellular Modem Monitor' 'Monitor line quality and type of Cellular Modems' ''
crash_function: cellmodem_t_delete
kernel:         3.6.5-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (5 frames)
: #1 cellmodem_t_delete at cellmodem.c:594
: #2 _g_closure_invoke_va at gclosure.c:840
: #5 xfce_panel_plugin_dispose at xfce-panel-plugin.c:759
: #7 gtk_container_destroy at gtkcontainer.c:1073
: #12 gtk_object_dispose at gtkobject.c:421

Comment 1 Jani Heinonen 2012-11-07 11:03:59 UTC
Created attachment 639949 [details]
File: var_log_messages

Comment 2 Jani Heinonen 2012-11-07 11:04:01 UTC
Created attachment 639950 [details]
File: core_backtrace

Comment 3 Jani Heinonen 2012-11-07 11:04:04 UTC
Created attachment 639951 [details]
File: environ

Comment 4 Jani Heinonen 2012-11-07 11:04:06 UTC
Created attachment 639952 [details]
File: limits

Comment 5 Jani Heinonen 2012-11-07 11:04:09 UTC
Created attachment 639953 [details]
File: backtrace

Comment 6 Jani Heinonen 2012-11-07 11:04:11 UTC
Created attachment 639954 [details]
File: cgroup

Comment 7 Jani Heinonen 2012-11-07 11:04:12 UTC
Created attachment 639955 [details]
File: smolt_data

Comment 8 Jani Heinonen 2012-11-07 11:04:14 UTC
Created attachment 639956 [details]
File: executable

Comment 9 Jani Heinonen 2012-11-07 11:04:17 UTC
Created attachment 639957 [details]
File: maps

Comment 10 Jani Heinonen 2012-11-07 11:04:18 UTC
Created attachment 639958 [details]
File: dso_list

Comment 11 Jani Heinonen 2012-11-07 11:04:20 UTC
Created attachment 639959 [details]
File: proc_pid_status

Comment 12 Jani Heinonen 2012-11-07 11:04:22 UTC
Created attachment 639960 [details]
File: open_fds

Comment 13 Christoph Wickert 2012-11-07 11:57:23 UTC
Thanks for submitting this crash report. What did you do when the plugin crashed? Can you reproduce the crash reliably? If so, how?

Comment 14 Jani Heinonen 2012-11-07 12:06:58 UTC
Hi!

I added Cellular Modem Monitor to top panel (panel 1). After this I decided not to use it, so right click above the Cellular Modem Monitor and select remove. It removes nicely but but causes the above crash.

This can be reproduced by

1. Add to panel 1
2. Wait for a while
3. Remove from panel by right click on CMM and remove.

Comment 15 Christoph Wickert 2012-11-07 12:16:16 UTC
You are right, sorry I didn't see your comment earlier. I can reproduce the crash, therefor I have forwarded your report to the upstream developer at https://bugzilla.xfce.org/show_bug.cgi?id=9470

Further investigation will happen upstream. I will let you know once the issue is resolved in Fedora or if I need more info. Thanks again for your bug report.

Comment 16 Christoph Wickert 2013-02-14 11:47:49 UTC
*** Bug 910993 has been marked as a duplicate of this bug. ***

Comment 17 Christoph Wickert 2013-02-14 13:25:07 UTC
Update is on it's way, stay tuned.

Comment 18 Christoph Wickert 2013-02-14 13:31:31 UTC
*** Bug 651196 has been marked as a duplicate of this bug. ***

Comment 19 Christoph Wickert 2013-02-14 13:31:39 UTC
*** Bug 602662 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2013-02-14 17:23:03 UTC
xfce4-cellmodem-plugin-0.0.5-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xfce4-cellmodem-plugin-0.0.5-11.fc17

Comment 21 Fedora Update System 2013-02-14 18:43:57 UTC
xfce4-cellmodem-plugin-0.0.5-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfce4-cellmodem-plugin-0.0.5-11.fc18

Comment 22 Fedora Update System 2013-02-16 00:53:27 UTC
Package xfce4-cellmodem-plugin-0.0.5-11.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-cellmodem-plugin-0.0.5-11.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2508/xfce4-cellmodem-plugin-0.0.5-11.fc18
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2013-02-28 07:08:42 UTC
xfce4-cellmodem-plugin-0.0.5-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2013-02-28 07:10:43 UTC
xfce4-cellmodem-plugin-0.0.5-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.