Bug 875278 - AttributeError: 'NoneType' object has no attribute 'type'
AttributeError: 'NoneType' object has no attribute 'type'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:f3b0168fa52c7aa876ee07d55d8...
:
: 875999 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-09 22:17 EST by Steve Tyler
Modified: 2012-11-23 02:27 EST (History)
16 users (show)

See Also:
Fixed In Version: anaconda-18.29.1-
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 01:42:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: ifcfg.log (641 bytes, text/plain)
2012-11-09 22:17 EST, Steve Tyler
no flags Details
File: anaconda-tb (1.20 MB, text/plain)
2012-11-09 22:17 EST, Steve Tyler
no flags Details
File: environ (876 bytes, text/plain)
2012-11-09 22:17 EST, Steve Tyler
no flags Details
File: type (9 bytes, text/plain)
2012-11-09 22:17 EST, Steve Tyler
no flags Details
File: executable (14 bytes, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: storage.log (629.63 KB, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: version (2 bytes, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: program.log (316.36 KB, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: product (6 bytes, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: anaconda.log (45.65 KB, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: cmdline_file (162 bytes, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: release (33 bytes, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: messages (202.77 KB, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details
File: other involved packages (32 bytes, text/plain)
2012-11-09 22:18 EST, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-11-09 22:17:48 EST
Version-Release number of selected component:
anaconda-18.28-1.fc18.x86_64

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.5-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.28 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1245, in install_targets
:    if self.stage2_device.type == "mdarray" and \
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1571, in check
:    for (stage1dev, stage2dev) in self.install_targets:
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1551, in sanityCheck
:    if not self.bootloader.check():
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 308, in checkStorage
:    StorageChecker.warnings) = self.storage.sanityCheck()
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:AttributeError: 'NoneType' object has no attribute 'type'
Comment 1 Steve Tyler 2012-11-09 22:17:50 EST
Created attachment 641970 [details]
File: ifcfg.log
Comment 2 Steve Tyler 2012-11-09 22:17:56 EST
Created attachment 641971 [details]
File: anaconda-tb
Comment 3 Steve Tyler 2012-11-09 22:17:57 EST
Created attachment 641972 [details]
File: environ
Comment 4 Steve Tyler 2012-11-09 22:17:59 EST
Created attachment 641973 [details]
File: type
Comment 5 Steve Tyler 2012-11-09 22:18:00 EST
Created attachment 641974 [details]
File: executable
Comment 6 Steve Tyler 2012-11-09 22:18:03 EST
Created attachment 641975 [details]
File: storage.log
Comment 7 Steve Tyler 2012-11-09 22:18:05 EST
Created attachment 641976 [details]
File: version
Comment 8 Steve Tyler 2012-11-09 22:18:07 EST
Created attachment 641977 [details]
File: program.log
Comment 9 Steve Tyler 2012-11-09 22:18:08 EST
Created attachment 641978 [details]
File: product
Comment 10 Steve Tyler 2012-11-09 22:18:10 EST
Created attachment 641979 [details]
File: anaconda.log
Comment 11 Steve Tyler 2012-11-09 22:18:11 EST
Created attachment 641980 [details]
File: hashmarkername
Comment 12 Steve Tyler 2012-11-09 22:18:13 EST
Created attachment 641981 [details]
File: cmdline_file
Comment 13 Steve Tyler 2012-11-09 22:18:15 EST
Created attachment 641982 [details]
File: release
Comment 14 Steve Tyler 2012-11-09 22:18:16 EST
Created attachment 641983 [details]
File: messages
Comment 15 Steve Tyler 2012-11-09 22:18:18 EST
Created attachment 641984 [details]
File: other involved packages
Comment 16 Steve Tyler 2012-11-09 23:23:35 EST
Here is a reproducer:

Create a 12 GB disc image.[1]

Complete a minimal F17 install[2] with standard partitions and default partitioning using the DVD.[3]

Start the F18-Beta-TC7 Live CD and update anaconda using koji and yum.[4]

Click Installation Destination.
Click Continue.
Check "I don't need help ...".
Click Reclaim space.
Click "+" to expand list of preexisting partitions.
Click "+" to expand Customize list.
For each of the three partitions (Boot, Root, Swap):
    Select it, Check Reformat, Click Apply changes.
Click Finish Partitioning.
Exception occurs: AttributeError: 'NoneType' object has no attribute 'type'.

[1] $ qemu-img create f18-test-2.img 12G

[2] $ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F17/Fedora-17-x86_64-DVD.iso -usb -vga qxl -boot menu=on -usbdevice mouse

[3] Uncheck "Use LVM" in the installation type dialog.
    Click the "Use All Space" button.

[4] $ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC7/Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 17 Steve Tyler 2012-11-10 00:14:27 EST
The F18 default LVM partitioning scheme can be used instead as a starting point for the reproducer. Verified by removing all of the F17 partitions, auto-creating new partitions, and completing a Live CD install.
Comment 18 Reartes Guillermo 2012-11-10 16:58:24 EST
i went to manual partitioning and tried to rehuse a partition.

the system has a previous f17 instance with a raid5 and other disk for /, /boot and swap


Package: anaconda-18.28
OS Release: Fedora release 18-Beta-TC8
Comment 19 Chris Lumens 2012-11-13 23:35:08 EST
*** Bug 875999 has been marked as a duplicate of this bug. ***
Comment 20 Kamil Páral 2012-11-15 04:00:00 EST
I entered the custom partitioning screen, made no changes at all, and clicked Finish partitioning (becase I simply wanted to return back). Error appeared.

Package: anaconda-18.28
OS Release: Fedora release 18-Beta-TC8
Comment 21 David Lehman 2012-11-15 09:57:58 EST
Either BootLoader.check or Storage.sanityCheck needs to make sure the bootloader is configured before doing the check.
Comment 22 Mateusz Marzantowicz 2012-11-16 13:49:31 EST
It happened after clicking on "Finish partitioning" button.

I had previous installation of Fedora 18 on disk. I had to make some room for new installation (I was unable to find option to override existing install automatically). I've deleted all partitions (root, swap, boot) and clicked "Finish partitioning" and then it happened!


Package: anaconda-18.28
OS Release: Fedora release 18-Beta-TC8
Comment 23 Brian Lane 2012-11-16 17:21:40 EST
Proposing as a blocker. Criteria? It makes things blow up. Granted you can work around it by setting things up before leaving custom, but...
Comment 24 Adam Williamson 2012-11-16 18:50:46 EST
I'm +1 NTH at the very least for this.
Comment 25 Dennis Gilmore 2012-11-16 18:57:45 EST
i am +1 nth, could be convinced its a blocker if it turns out to be a common use case.
Comment 26 Kevin Fenzi 2012-11-16 19:00:11 EST
Definitely +1 NTH. A weak +1 blocker... it could be worked around/noted, but it would look pretty bad for beta. ;(
Comment 27 Tim Flink 2012-11-16 20:04:54 EST
+1 NTH. THat makes +4 NTH, moving to accepted.
Comment 29 Flóki Pálsson 2012-11-17 10:06:47 EST
Trying to install to /dev/sdc13 with mount /

Package: anaconda-18.29
OS Release: Fedora release 18-Beta-TC9
Comment 30 Fedora Update System 2012-11-18 20:14:32 EST
anaconda-18.29.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.29.1-1.fc18
Comment 31 Fedora Update System 2012-11-19 01:55:41 EST
Package anaconda-18.29.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.29.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.1-1.fc18
then log in and leave karma (feedback).
Comment 32 Kamil Páral 2012-11-21 10:54:58 EST
This is fixed with anaconda 18.29.2 (Beta RC1). The reproducer in comment 16 crashed anaconda in 18.28 and doesn't crash now. That doesn't mean it works now, I've hit some other issues with custom partitioning (I'll report it), but this one is fixed now.
Comment 33 Adam Williamson 2012-11-23 01:42:22 EST
18.29.2-1 is going stable now, so closing.
Comment 34 Fedora Update System 2012-11-23 02:27:20 EST
anaconda-18.29.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.